aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Ward (JIRA)" <j...@apache.org>
Subject [jira] [Created] (ARIES-1534) Hibernate is only usable if the persistence bundle has dynamic imports
Date Fri, 15 Apr 2016 13:35:25 GMT
Timothy Ward created ARIES-1534:
-----------------------------------

             Summary: Hibernate is only usable if the persistence bundle has dynamic imports
                 Key: ARIES-1534
                 URL: https://issues.apache.org/jira/browse/ARIES-1534
             Project: Aries
          Issue Type: Bug
          Components: JPA
            Reporter: Timothy Ward


The JPA container tests have the following in the persistence bundle.

    DynamicImport-Package: \
        org.hibernate.proxy, \
        javassist.util.proxy


Dynamic imports should never be necessary, and these are totally unscoped. This needs to be
fixed, either in Hibernate or in Aries JPA



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message