aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "AmirMohammad Vosough (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ARIES-1777) need to add aries-blueprint as a dependency to jpa feature
Date Sat, 10 Feb 2018 10:49:00 GMT

    [ https://issues.apache.org/jira/browse/ARIES-1777?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16359367#comment-16359367
] 

AmirMohammad Vosough commented on ARIES-1777:
---------------------------------------------

2018-02-10T18:41:54,702 | ERROR | CM Configuration Updater (ManagedService Update: pid=[org.apache.aries.jpa.amvPersistenceUnit])
| configadmin | 7 - org.apache.felix.configadmin - 1.8.14 | [org.osgi.service.cm.ManagedService,
id=187, unregistered]: Unexpected problem updating configuration org.apache.aries.jpa.amvPersistenceUnit
java.lang.IllegalStateException: Invalid BundleContext.
 at org.apache.felix.framework.BundleContextImpl.checkValidity(BundleContextImpl.java:511)
[?:?]
 at org.apache.felix.framework.BundleContextImpl.createFilter(BundleContextImpl.java:127)
[?:?]
 at org.osgi.util.tracker.ServiceTracker.<init>(ServiceTracker.java:184) [?:?]
 at org.hibernate.osgi.OsgiServiceUtil.getServiceTracker(OsgiServiceUtil.java:83) [141:org.hibernate.osgi:5.2.8.Final]
 at org.hibernate.osgi.OsgiServiceUtil.getServiceImpls(OsgiServiceUtil.java:47) [141:org.hibernate.osgi:5.2.8.Final]
 at org.hibernate.osgi.OSGiClassLoaderServiceImpl.loadJavaServices(OSGiClassLoaderServiceImpl.java:34)
[141:org.hibernate.osgi:5.2.8.Final]
 at org.hibernate.osgi.OSGiClassLoaderServiceImpl.loadJavaServices(OSGiClassLoaderServiceImpl.java:20)
[141:org.hibernate.osgi:5.2.8.Final]
 at org.hibernate.boot.model.process.spi.MetadataBuildingProcess.handleTypes(MetadataBuildingProcess.java:356)
[140:org.hibernate.core:5.2.8.Final]
 at org.hibernate.boot.model.process.spi.MetadataBuildingProcess.complete(MetadataBuildingProcess.java:111)
[140:org.hibernate.core:5.2.8.Final]
 at org.hibernate.jpa.boot.internal.EntityManagerFactoryBuilderImpl.metadata(EntityManagerFactoryBuilderImpl.java:858)
[140:org.hibernate.core:5.2.8.Final]
 at org.hibernate.jpa.boot.internal.EntityManagerFactoryBuilderImpl.build(EntityManagerFactoryBuilderImpl.java:885)
[140:org.hibernate.core:5.2.8.Final]
 at org.hibernate.osgi.OsgiPersistenceProvider.createContainerEntityManagerFactory(OsgiPersistenceProvider.java:96)
[141:org.hibernate.osgi:5.2.8.Final]
 at org.apache.aries.jpa.container.impl.ManagedEMF.createAndPublishEMF(ManagedEMF.java:129)
[83:org.apache.aries.jpa.container:2.6.1]
 at org.apache.aries.jpa.container.impl.ManagedEMF.updated(ManagedEMF.java:125) [83:org.apache.aries.jpa.container:2.6.1]
 at org.apache.felix.cm.impl.helper.ManagedServiceTracker.updated(ManagedServiceTracker.java:189)
[7:org.apache.felix.configadmin:1.8.14]
 at org.apache.felix.cm.impl.helper.ManagedServiceTracker.updateService(ManagedServiceTracker.java:152)
[7:org.apache.felix.configadmin:1.8.14]
 at org.apache.felix.cm.impl.helper.ManagedServiceTracker.provideConfiguration(ManagedServiceTracker.java:85)
[7:org.apache.felix.configadmin:1.8.14]
 at org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.provide(ConfigurationManager.java:1463)
[7:org.apache.felix.configadmin:1.8.14]
 at org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.run(ConfigurationManager.java:1419)
[7:org.apache.felix.configadmin:1.8.14]
 at org.apache.felix.cm.impl.UpdateThread.run0(UpdateThread.java:141) [7:org.apache.felix.configadmin:1.8.14]
 at org.apache.felix.cm.impl.UpdateThread.run(UpdateThread.java:109) [7:org.apache.felix.configadmin:1.8.14]
 at java.lang.Thread.run(Thread.java:748) [?:?]

> need to add aries-blueprint as a dependency to jpa feature
> ----------------------------------------------------------
>
>                 Key: ARIES-1777
>                 URL: https://issues.apache.org/jira/browse/ARIES-1777
>             Project: Aries
>          Issue Type: Bug
>          Components: JPA
>    Affects Versions: jpa-2.6.1
>            Reporter: AmirMohammad Vosough
>            Priority: Major
>              Labels: easyfix
>             Fix For: jpa-2.7.0
>
>   Original Estimate: 2h
>  Remaining Estimate: 2h
>
> When working on Vaseline framework, I faced this problem:
> After using karaf-assembly I found out I can not have jpa as a startup feature.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message