aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Resolved] (ARIES-1796) avoid IllegalArgumentException "Invalid Java version 54" when use proxy-impl with java10
Date Wed, 06 Jun 2018 19:53:01 GMT

     [ https://issues.apache.org/jira/browse/ARIES-1796?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jean-Baptiste Onofré resolved ARIES-1796.
-----------------------------------------
    Resolution: Fixed

> avoid IllegalArgumentException "Invalid Java version 54" when use proxy-impl with java10
> ----------------------------------------------------------------------------------------
>
>                 Key: ARIES-1796
>                 URL: https://issues.apache.org/jira/browse/ARIES-1796
>             Project: Aries
>          Issue Type: Task
>          Components: Proxy
>            Reporter: Freeman Fang
>            Assignee: Jean-Baptiste Onofré
>            Priority: Major
>             Fix For: proxy-impl-1.1.2
>
>         Attachments: ARIES-1796.patch
>
>
> If we run blueprint enabled bundle in Karaf in java10, we can see this exception.
> The ProxyUtils class cannot recognize the java10 class version 54



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message