aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "matteo rulli (Jira)" <j...@apache.org>
Subject [jira] [Updated] (ARIES-1925) org.apache.aries.transaction.blueprint/1.1.1 is not wired to TransactionManager
Date Wed, 04 Sep 2019 13:16:00 GMT

     [ https://issues.apache.org/jira/browse/ARIES-1925?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

matteo rulli updated ARIES-1925:
--------------------------------
    Attachment: filtered-logs.log

> org.apache.aries.transaction.blueprint/1.1.1 is not wired to TransactionManager
> -------------------------------------------------------------------------------
>
>                 Key: ARIES-1925
>                 URL: https://issues.apache.org/jira/browse/ARIES-1925
>             Project: Aries
>          Issue Type: Bug
>          Components: Transaction
>    Affects Versions: transaction-blueprint-1.1.1
>         Environment: Apache Karaf 4.2.6; Posgres and OpenJPA 3.0.0
>            Reporter: matteo rulli
>            Priority: Major
>         Attachments: filtered-logs.log
>
>
> We are using aries org.apache.aries.transaction.blueprint with Apache Karaf. Quite frequently
we get the following error:
> {code}
> Apache Aries Transaction Blueprint (121)
> ----------------------------------------
> Status: Waiting
> Blueprint
> 9/4/19 2:52 PM
> Missing dependencies:
> (objectClass=javax.transaction.TransactionManager)
> Declarative Services
> {code}
> with 
> {code}
> 121 │ Waiting     │  80 │ 1.1.1                 │ org.apache.aries.transaction.blueprint
> 122 │ Active      │  80 │ 2.2.0                 │ org.apache.aries.transaction.blueprint
> {code}
> and this prevents some bundles that use JPA to start.
> I cannot understand what it is going on exactly but and why the org.apache.aries.transaction.blueprint/1.1.1
fails to get the TransactionManager reference, but if I manually do
> {code}
> stop 121
> start 121
> {code}
> the org.apache.aries.transaction.blueprint/1.1.1 bundle starts ok and everything works
as expected. Some logs attached.



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

Mime
View raw message