aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: java.lang.IllegalArgumentException with Blueprint Core 1.10.2
Date Mon, 25 Nov 2019 13:23:13 GMT
Does it work with those bundles ?

Regards
JB

On 25/11/2019 14:05, Martin Petzold wrote:
> Working with:
> 
> asm-7.2.jar
> asm-analysis-7.2.jar
> asm-commons-7.2.jar
> asm-tree-7.2.jar
> asm-util-7.2.jar
> 
> Am 25.11.19 um 13:53 schrieb Martin Petzold:
>> Hi JB,
>>
>> thanks, can you tell me the exact bundle?
>>
>> Kind regards,
>>
>> Martin
>>
>> Am 25.11.19 um 13:47 schrieb Jean-Baptiste Onofré:
>>> Hi Martin,
>>>
>>> Can you please try with ASM 7.2 ? Especially if you try to use JDK 9+,
>>> you have to use ASM 7.2.
>>>
>>> We are using Blueprint Core 1.10.2 in Karaf without problem up to now.
>>>
>>> Regards
>>> JB
>>>
>>> On 25/11/2019 13:26, Martin Petzold wrote:
>>>> Dear all,
>>>>
>>>> I switched from Blueprint Core 1.8.2 to 1.10.2. The reason is that I
>>>> had
>>>> some errors switching from Java 1.8 to Java 11. Now I get an Exception:
>>>>
>>>> org.osgi.service.blueprint.container.ComponentDefinitionException:
>>>> java.lang.IllegalArgumentException
>>>>      at
>>>> org.apache.aries.blueprint.container.ReferenceRecipe.internalCreate(ReferenceRecipe.java:141)
>>>>
>>>>
>>>>
>>>> ...
>>>> Caused by: java.lang.IllegalArgumentException: null
>>>>      at org.objectweb.asm.ClassVisitor.<init>(ClassVisitor.java:79)
>>>>
>>>> I am using most recent Equinox OSGi implementation with custom launcher
>>>> and a selected bundle set. The OLD BUNDLE run well since months!
>>>>
>>>> -> What can I do?
>>>>
>>>> --- NEW BUNDLES
>>>>
>>>> org.apache.aries.blueprint.api-1.0.1.jar
>>>> org.apache.aries.blueprint.core-1.10.2.jar
>>>> org.apache.aries.proxy-1.1.6.jar
>>>> org.apache.aries.proxy.api-1.1.0.jar
>>>> org.apache.aries.quiesce.api-1.0.0.jar
>>>> org.apache.aries.spifly.dynamic.bundle-1.2.3.jar
>>>> org.apache.aries.util-1.1.3.jar
>>>> asm-debug-all-5.2.jar
>>>>
>>>> --- OLD BUNDLES
>>>>
>>>> org.apache.aries.blueprint.api-1.0.1.jar
>>>> org.apache.aries.blueprint.core-1.8.2.jar
>>>> org.apache.aries.proxy-1.1.1.jar
>>>> org.apache.aries.proxy.api-1.1.0.jar
>>>> org.apache.aries.quiesce.api-1.0.0.jar
>>>> org.apache.aries.spifly.dynamic.bundle-1.0.8.jar
>>>> org.apache.aries.util-1.1.3.jar
>>>> asm-debug-all-5.0.3.jar
>>>>
>>>> ---
>>>>
>>>> Thanks and kind regards,
>>>>
>>>> Martin
>>>>

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message