aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Veselin (Jira)" <j...@apache.org>
Subject [jira] [Commented] (ARIES-1765) Aries JPA - Update to JPA 2.2
Date Sat, 01 Feb 2020 18:04:00 GMT

    [ https://issues.apache.org/jira/browse/ARIES-1765?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17028174#comment-17028174
] 

Veselin commented on ARIES-1765:
--------------------------------

I'm using version aries-jpa 2.7.2 with eclipselink 2.7.5 also but I get following exception:

Unable to resolve org.apache.aries.jpa.container [43](R 43.0): missing requirement [org.apache.aries.jpa.container
[43](R 43.0)] osgi.contract; (&(osgi.contract=JavaJPA)(|(version=2)(version=2.1))(!(version>=2.2)))
Unresolved requirements: [[org.apache.aries.jpa.container [43](R 43.0)] osgi.contract; (&(osgi.contract=JavaJPA)(|(version=2)(version=2.1))(!(version>=2.2)))]

 

How do you get this to work if eclipselink supplies JavaJPA 2.2? Should I change the manifest
of org.apache.aries.jpa.container?

> Aries JPA - Update to JPA 2.2
> -----------------------------
>
>                 Key: ARIES-1765
>                 URL: https://issues.apache.org/jira/browse/ARIES-1765
>             Project: Aries
>          Issue Type: Bug
>          Components: JPA
>    Affects Versions: jpa-2.6.0
>            Reporter: Giuseppe Gerla
>            Priority: Minor
>
> Because eclipselink delivered 2.7.0 version that is based on JPA 2.2, could be useful
to verify and eventually introduce compliance with this new version of API.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message