asterixdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vignesh Raghunathan <vignesh.raghunatha...@gmail.com>
Subject Re: Error while running maven commands
Date Tue, 24 Nov 2015 23:21:20 GMT
Hi,

Thank you for the responses. I am able to run maven commands after updating
to the latest code. I am also able to run the tests using mvn test -pl
asterix-installer.

However, I am not sure if that command is enabling the clusterTest profile
defined in incubator-asterixdb/asterix-installer/pom.xml. My objective is
to enable the clusterTest profile and run the integration tests in
asterix-installer. Following that, I want to add a new Vagrantfile and run
the tests on a real cluster (using
https://github.com/tknerr/vagrant-managed-servers). That way I can tell if
there are any differences between the two.

I am getting an error related to the version of vagrant-maven-plugin if I
run "mvn integration-test -DclusterTest=true" inside asterix-installer. If
I change the version to 1.0.1, I am getting the following error:

[ERROR] Failed to execute goal
net.ju-n.maven.plugins:vagrant-maven-plugin:1.0.1:up
(setup-and-start-vagrant-vm) on project asterix-installer: Execution
setup-and-start-vagrant-vm of goal
net.ju-n.maven.plugins:vagrant-maven-plugin:1.0.1:up failed: A required
class was missing while executing
net.ju-n.maven.plugins:vagrant-maven-plugin:1.0.1:up:
org/sonatype/aether/RepositorySystemSession

Is there a workaround for this?

Thanks,

Vignesh








On Tue, Nov 24, 2015 at 4:38 AM, abdullah alamoudi <bamousaa@gmail.com>
wrote:

> Another easy and quick way to handle this is to cd to the top level folder
> aka "incubator-asterixdb" and invoke mvn with the -pl flag.
> For example:
> mvn test -pl asterix-installer
>
> Cheers,
> Abdullah.
>
> Amoudi, Abdullah.
>
> On Mon, Nov 23, 2015 at 10:33 PM, Chris Hillery <chillery@hillery.land>
> wrote:
>
> > Do you have the latest code on incubator-asterixdb master? The error you
> > list is coming from the invocation of the maven-assembly-plugin for
> > generating the source .zip, and that should only be invoked if you
> > explicitly enable the "asterix-release" Maven profile unless you have
> code
> > prior to my commit 79dfcfc. I'm assuming you're not enabling the
> > "asterix-release" profile explicitly.
> >
> > Ceej
> > aka Chris Hillery
> >
> > On Mon, Nov 23, 2015 at 8:36 PM, Vignesh Raghunathan <
> > vignesh.raghunathan90@gmail.com> wrote:
> >
> > > Hi,
> > >
> > > I have been trying to run an integration test
> (AsterixClusterLifeCycleIT)
> > > to check how vagrant is being used by the test. However, if I run mvn
> > > integration-test -DclusterTest=true inside asterix-installer folder, I
> am
> > > getting the following error:
> > >
> > > [ERROR] Error:
> > >
> > > [ERROR] java.net.MalformedURLException: no protocol:
> > > src/main/assembly/source.xml
> > >
> > > [ERROR] at java.net.URL.<init>(URL.java:586)
> > >
> > > [ERROR] at java.net.URL.<init>(URL.java:483)
> > >
> > > [ERROR] at java.net.URL.<init>(URL.java:432)
> > >
> > > [ERROR] at
> > >
> > >
> >
> org.apache.maven.shared.io.location.URLLocatorStrategy.resolve(URLLocatorStrategy.java:54)
> > >
> > > [ERROR] at
> > > org.apache.maven.shared.io.location.Locator.resolve(Locator.java:81)
> > >
> > > [ERROR] at
> > >
> > >
> >
> org.apache.maven.plugin.assembly.io.DefaultAssemblyReader.addAssemblyFromDescriptor(DefaultAssemblyReader.java:309)
> > >
> > > [ERROR] at
> > >
> > >
> >
> org.apache.maven.plugin.assembly.io.DefaultAssemblyReader.readAssemblies(DefaultAssemblyReader.java:140)
> > >
> > > [ERROR] at
> > >
> > >
> >
> org.apache.maven.plugin.assembly.mojos.AbstractAssemblyMojo.execute(AbstractAssemblyMojo.java:352)
> > >
> > > [ERROR] at
> > >
> > >
> >
> org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134)
> > > ......
> > >
> > > .....
> > >
> > > .....
> > >
> > > This is the case whenever I try to run a maven command in one of the
> > > subfolders in incubator-asterixdb. The commands run fine if I invoke
> them
> > > in incubator-asterixdb folder. How can I resolve this problem?
> > >
> > >
> > > Thanks,
> > >
> > > Vignesh
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message