atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Speidel <>
Subject Re: Atlas build
Date Tue, 01 Sep 2015 01:54:48 GMT
Yeah, that is a know issue.  Simply creating an empty war file before the build will allow
the build to succeed.


Sent from my iPad

> On Aug 31, 2015, at 9:51 PM, Aaron.Dossett <> wrote:
> Hello,
> It has been a few months since I have been in the Atlas code base, but looking forward
to getting reacquainted with it.
> I cloned the repo today (via github) and tried to build the code per instructions in
InstallationSteps.twiki but `mvn clean install` fails with this error:
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-assembly-plugin:2.2.1:single
(default) on project apache-atlas: Failed to create assembly: Error adding file to archive:
/myhomedir/apache/atlas/webapp/target/atlas-webapp-0.6-incubating-SNAPSHOT.war isn't a file.
-> [Help 1]
> Is `mvn clean install` still the correct first build step?  I see that the assembly plugin
is using the `single` goal now, which is good.  In another project I worked on, the assembly
step had to be moved into its own module to get the maven dependencies to work correctly when
moving to assembly:single.  Apache Knox also does something like this, and it’s a very clean
> Is there another way I should be building Atlas?  Would moving the assembly step into
its own module be helpful?  If so I can open a JIRA and work on that.
> Best, Aaron

View raw message