atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Girish Ramachandran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ATLAS-263) Searching for a multi word trait always returns empty result
Date Tue, 01 Dec 2015 08:49:11 GMT

    [ https://issues.apache.org/jira/browse/ATLAS-263?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15033358#comment-15033358
] 

Girish Ramachandran commented on ATLAS-263:
-------------------------------------------

@Shwetha G S - Can you please review the fix?



> Searching for a multi word trait always returns empty result
> ------------------------------------------------------------
>
>                 Key: ATLAS-263
>                 URL: https://issues.apache.org/jira/browse/ATLAS-263
>             Project: Atlas
>          Issue Type: Bug
>    Affects Versions: 0.6-incubating
>            Reporter: Ayub Khan
>            Priority: Blocker
>         Attachments: types_query_fix.patch
>
>
> Searching for a multi word trait always returns empty result..
> 1. Create a trait name with multiple words..
> 	Example: 
> {noformat}
> curl 'http://localhost:21000/api/atlas/types' -H 'Origin: http://localhost:21000'  -H
'Content-Type: application/json;charset=UTF-8' --data-binary '{"enumTypes":[],"traitTypes":[{"superTypes":[],"typeName":"multi
word trait","attributeDefinitions":[],"hierarchicalMetaTypeName":"org.apache.atlas.typesystem.types.TraitType"}],"structTypes":[],"classTypes":[]}'
--compressed
> {noformat}
> 2. Attach the tag with an entity
> 	Example:
> {noformat}
> curl -v 'http://localhost:21000/api/atlas/entity/803f5bdd-28f9-49e1-8c21-3dc0f9fd5c61/traits'
-H 'Content-Type: application/json;charset=UTF-8' --data-binary '{"jsonClass":"org.apache.atlas.typesystem.json.InstanceSerialization$_Struct","typeName":"multi
word trait","values":{}}' --compressed
> {noformat}
> 3. Now try to get all the entities associated with the tag
> 	Example:
> {noformat}
> curl 'http://localhost:21000/api/atlas/discovery/search?query=multi+word+trait'
> {noformat}
> 	
> 	Result of the above is always empty because the above query is triggered as "full text"
and it always returns empty result even if you have associated entites to the tag.
> 	
> This is a big issue from an end user's perspective. marking this as a blocker



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message