atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suma Shivaprasad (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ATLAS-346) Atlas server loses messages sent from Hive hook if restarted after unclean shutdown
Date Sat, 12 Dec 2015 10:06:46 GMT

    [ https://issues.apache.org/jira/browse/ATLAS-346?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15054196#comment-15054196
] 

Suma Shivaprasad commented on ATLAS-346:
----------------------------------------

Build succeeds for the patch 

[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO]
[INFO] apache-atlas ....................................... SUCCESS [  5.722 s]
[INFO] Apache Atlas Common ................................ SUCCESS [  9.189 s]
[INFO] Apache Atlas Typesystem ............................ SUCCESS [ 46.908 s]
[INFO] Apache Atlas Server API ............................ SUCCESS [  5.558 s]
[INFO] Apache Atlas Client ................................ SUCCESS [ 15.424 s]
[INFO] Apache Atlas Notification .......................... SUCCESS [ 14.212 s]
[INFO] Apache Atlas Titan ................................. SUCCESS [ 18.916 s]
[INFO] Apache Atlas Repository ............................ SUCCESS [03:56 min]
[INFO] Apache Atlas UI .................................... SUCCESS [01:30 min]
[INFO] Apache Atlas Web Application ....................... SUCCESS [02:29 min]
[INFO] Apache Atlas Documentation ......................... SUCCESS [  3.723 s]
[INFO] Apache Atlas Hive Bridge ........................... SUCCESS [01:12 min]
[INFO] Apache Atlas Distribution .......................... SUCCESS [ 32.675 s]
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 11:42 min
[INFO] Finished at: 2015-12-12T15:32:03+05:30
[INFO] Final Memory: 183M/715M
[INFO] ------------------------------------------------------------------------

> Atlas server loses messages sent from Hive hook if restarted after unclean shutdown
> -----------------------------------------------------------------------------------
>
>                 Key: ATLAS-346
>                 URL: https://issues.apache.org/jira/browse/ATLAS-346
>             Project: Atlas
>          Issue Type: Bug
>            Reporter: Hemanth Yamijala
>            Assignee: Hemanth Yamijala
>            Priority: Critical
>         Attachments: ATLAS-346.patch, ATLAS-346.patch, hive_server2_import_bug_snip.txt
>
>
> * Start Atlas server pointed to an external Kafka instance
> * Configure HiveServer2 with Atlas hook pointing to the same Kafka instance.
> * Run a hive DDL script like 
> {code}
> for i in `seq 1 25`; do ./bin/beeline -u jdbc:hive2://localhost:10000 -n ${user} -p ${pass}
-e "create table tbl${i} (col${i}1 int, col${i}2 string);"; done
> {code}
> * While the script is executing, kill -9 the Atlas server
> * Let the script complete.
> * Verify that all the events are added to the ATLAS_HOOK topic.
> * Verify if the tables are added to Atlas.
> The observation is that the Kafka topic has all relevant messages, but the tables aren't
added to Atlas.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message