axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Elie J. Pyatkevich" <>
Subject run-time exception
Date Mon, 23 Feb 2004 17:28:19 GMT

Just tried Axis 1.1 for Java and it works great, excellent job guys.

When I tried Axis 1.0 for C++ ran into some problems building c++ stubs 
from a WSDL file.
Looked at your recent CVS mods and saw that you guys have actually fixed that
problem and tried to get the lastest code to work:
	1. downloaded today's snapshot (feb 23rd) sources
	2. built AXISCPP_HOME/java jars without a problem
	3. modified AXISCPP_HOME/c/src/wsdl/build.xml to point to the right 
folders for "lib" and "src"
	4. built AXISCPP_HOME/c/src/wsdl wsdl2ws.jar without a problem
	5. tried to run the WSDL2Ws tool again from the new wsdl2ws.jar file but 
now I get a run time

org.apache.axis.wsdl.symbolTable.SchemaUtils.getArrayComponentQName() ...

Has anyone else run into this problem as well?

Snooped around a bit and realized that you guys have similar code under the 
same package and class names for the axis.jar
and the wsdl2ws.jar.  Specifically these files are under both trees right now:

Do you want to merge the additional functionality that currently exists 
under the 
$AXISCPP_HOME/c/src/wsdl/org/apache/axis/wsdl/symbolTable/ into
and follow the same step for the file as well?  Or maybe 
these two
classes should be renamed under the $AXISCPP_HOME/c/src/wsdl/... tree?

Thanks for your help,


View raw message