axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leo Stutzmann" <lstutzm...@platform.com>
Subject RE: Axis C++ Question.
Date Mon, 16 Feb 2004 20:29:33 GMT
Thank you very much for the response.
 
The bugzilla page does not indicate where this is fixed, and how I get it.
 
The entire CVS tree as it exists today, does not build.
 
Leo

-----Original Message-----
From: Datey, Ameya [mailto:Ameya.Datey@ca.com]
Sent: Friday, February 13, 2004 10:06 AM
To: Apache AXIS C Developers List
Subject: RE: Axis C++ Question.


Leo
 
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=24096
 
Pls refer to some old emails I have attached. 
 
ameya
-------------- Original Message ----------------
Can you please submit a bug report with a patch for this? That'll make sure it gets fixed
for everyone ..

Thanks!

Sanjiva.

----- Original Message -----

From: "Roland Kosovsky" <nospam_kosovsky@abacus.ch>

To: "Apache AXIS C User List" <axis-c-user@ws.apache.org>

Sent: Thursday, January 15, 2004 9:04 PM

Subject: Re: SimpleAxisServer

 

> In my case the crash was caused by "sstr->so.http.op_headercount" that 

> was not set to 0.

> 

> mod_axis2.c, Ln 138:

> static int mod_axis_method_handler (request_rec *req_rec)

> ...

> sstr = malloc(sizeof(Ax_soapstream));

> memset(sstr, 0, sizeof(Ax_soapstream)); // <<<<< insert this line

> 

> This code has some more bugs, look at this:

> ...

> if(0 != process_request(sstr))

> {

> /*ap_rputs("SOAP Engine failed to response",req_rec);*/

> return OK; // #### sstr will never be freed!!!!!

> }

> if (sstr->so.http.op_headers)

> free(sstr->so.http.op_headers);

> free(sstr);

> 

> Why is the Ax_soapstream not on stack? It would be deleted for free.

> Roland

> 

> 

> 

> Datey, Ameya wrote:

> 

> >Hi All,

> >

> >I'm trying to run the simple axis server (running without apache), and

> >the program starts but then blows up if I do an HTTP request.

> >

> >I ran simpleaxisserver 8888 and then tried  <http://localhost:8888/> http://localhost:8888

> >

> >The program crashed & threw open my debugger.

> >

> >Any pointers?

> >Ameya

> >

> >Ps: Windows 2000 with ALL service packs

> >

> >

> >

> > 

> >

> 

 

 


  _____  

From: Leo Stutzmann [mailto:lstutzmann@platform.com] 
Sent: Friday, February 13, 2004 9:55 AM
To: axis-c-dev@ws.apache.org
Subject: Axis C++ Question.



Hi, 

I am new to using Axis C++, and may need help getting oriented in the right direction. 

I downloaded the Windows version of Axis C++ dated Dec 24, 2003. I installed it according
to the installation instructions.

I started the SimpleAxisServer using port 80 to try the examples. The server started and responds
with: 
Document parsing successful 
server.wsdd loading successful 

I start the base executable to run the tests and it says: 
invoking echoString... 
and then crashes with an acces violation in SimpleAxisServer.exe: 
AppName: simpleaxisserver.exe    AppVer: 0.0.0.0         ModName: simpleaxisserver.exe 
ModVer: 0.0.0.0  Offset: 0000f2c7 

I debugged the code and found the access violation at: 

    soap->so.http.op_headers[count].headername = pchkey; (in set_header() of Packet.cpp)


The count is set at the top of this function with soap->so.http.op_headercount, and op_headercount
is a bad value (large negative number).

I added an initializer statement to executework in simpleaxisserver: 
    str->so.http.ip_headercount = 0; 
    str->so.http.op_headercount = 0; 

To set the value to 0 as in the input header. 

Then when I run base, base finishes all the tests, but every test failed. 

I probably have done something wrong here, any help would be appreciated to get an installation
working, at least being able to run through the tests in base and groupB successfully.

thanks 
Leo 


Mime
View raw message