axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zolyomi Istvan (EXT-IT-Guru/Budapest)" <Ext-Istvan.Zoly...@Nokia.com>
Subject axis compilation problem
Date Wed, 10 Mar 2004 15:47:22 GMT

Hi,

Recently I've checked out the latest repository version of Axis C++. I
tried to build it, but I still have some problems. According to
descriptions, I've installed dependent development packages and copied
headers (I'm using apache2, so changed the config files according to
install guide). After a slight header modification in an apache2.0.40
header (had to change include <header> to "header" to find dependent
header), most libraries compile nicely. However, running for a noticable
amount of time, 'make' stops with an error what I couldn't resolve yet:

gcc -shared  mod_axis2.lo -Wl,--whole-archive
../../common/.libs/libcommon.al ../../engine/.libs/libengine.al
../../soap/.libs/libsoap.al ../../wsdd/.libs/libwsdd.al
./../xml/.libs/libxml.al -Wl,--no-whole-archive 
-L/home/scam/axis/c/lib/expat -L/home/scam/axis/c/lib/axis
-laxiscpp_client /usr/lib/libexpat.so -ldl -lstdc++  -Wl,-soname
-Wl,libaxiscpp_mod2.so.0 -o .libs/libaxiscpp_mod2.so.0.0.0
/usr/bin/ld: cannot find -laxiscpp_client
collect2: ld returned 1 exit status
make[4]: *** [libaxiscpp_mod2.la] Error 1
make[4]: Leaving directory `/home/scam/axis/c/build/src/server/apache2'

I'm unable to figure out why axiscpp_client library is not compiled or
found. Did I make something wrong? Is some generator/builder script
buggy?

-- 

thanks

Istvan

Mime
View raw message