axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Perry (JIRA)" <axis-c-...@ws.apache.org>
Subject [jira] Commented: (AXISCPP-231) ExceptionTest fails with a sigsegv.
Date Mon, 01 Nov 2004 15:14:34 GMT
     [ http://nagoya.apache.org/jira/browse/AXISCPP-231?page=comments#action_54882 ]
     
Andrew Perry commented on AXISCPP-231:
--------------------------------------

Samisa, I was refering to the ExceptionTestDocClient.cpp in the tests/auto_build/testcases/client/cpp
directory, not the tests/exceptionTest version, although the code is essentially the same.
The test firstly calls a valid endpoint which works successfully, then on the next iteration
it calls an invalid endpoint on a valid server:port which returns the HTTP 404 error below.

HTTP/1.1 404 Not Found^M
Server: WebSphere Application Server/5.1^M
Content-Type: text/html;charset=UTF-8^M
Content-Language: en-GB^M
Transfer-Encoding: chunked^M
^M
25^M
Error 404: File not found: services^M
^M
0^M
^M

It is hosted on a windows server, hence the ^M chars in the response.

It is the processing of this response that causes the SIGSEGV to be thrown. Any ideas?

The service is obviously from the response hosted on a WebSphere server and the posted request
is

POST /ExceptionTest/services HTTP/1.1
Host: localhost:13260
Content-Type: text/xml; charset=UTF-8
SOAPAction: ""
Content-Length: 383

<?xml version='1.0' encoding='utf-8' ?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SOAP-ENV:Body>
<ns1:div xmlns:ns1="http://soapinterop.org/wsdl">
<ns1:arg_0_0>10</ns1:arg_0_0>
<ns1:arg_1_0>5</ns1:arg_1_0>
</ns1:div>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>

The valid URL is /ExceptionTest/services/MathOps.


> ExceptionTest fails with a sigsegv.
> -----------------------------------
>
>          Key: AXISCPP-231
>          URL: http://nagoya.apache.org/jira/browse/AXISCPP-231
>      Project: Axis-C++
>         Type: Bug
>     Versions: current (nightly)
>  Environment: Linux and windows.
>     Reporter: Andrew Perry

>
> This test was working on friday with the 1.3 release, but now fails with a sigsegv. This
causes it to hang on windows.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://nagoya.apache.org/jira/secure/Administrators.jspa
-
If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


Mime
View raw message