axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "sanjaya singharage" <sanja...@opensource.lk>
Subject Re: Ant test framework - running a test
Date Mon, 10 Jan 2005 11:54:10 GMT
Is it possible to have a chat (irc on #apache-axiscpp ) andrew? Or shall we
continue the conversation through mail?

sanjaya.

----- Original Message -----
From: "Andrew Perry2" <PERRYAN@uk.ibm.com>
To: "Apache AXIS C Developers List" <axis-c-dev@ws.apache.org>
Cc: "Apache AXIS C Developers List" <axis-c-dev@ws.apache.org>
Sent: Monday, January 10, 2005 5:44 PM
Subject: Re: Ant test framework - running a test


>
>
>
>
> The Ant test framwork has been written so that the test can be run only
> with the delivered package and no trace of the build tree is installed.
> This means that dir.classes will not exist. I am current working on
> simplifying the parameters required.
>
> For now if you specify -Ddir.wsdl2ws=<path to wsdl2ws.jar> on the Ant
> command line or set it in a test specific properties file then it should
> work.
>
> Please do not change it as all the testing I do is on a separate machine
> using only the packaged deliverables so will stop working if you make your
> change.
>
> Regards,
>
>
> Andrew Perry
> IBM C/C++ Web Services Client
> perryan@uk.ibm.com
> Mail Point 127
> IBM UK Laboratories. Hursley Park, Winchester, Hants. SO21 2JN
> Tel. Internal 249828  External + 44 (0)1962 819828
> Fax. + 44(0)1962 818080
>
> "sanjaya singharage" <sanjayas@opensource.lk> wrote on 10/01/2005
11:17:39:
>
> > Hi all,
> >
> > When I try to run a test in the following manner on windows...
> >
> > ant -f
> > test.xml -Ddir.xmlParser=XMLPARSER_HOME -Ddir.package=PACKAGE
> -Dtest.name=Ca
> > lculator
> >
> > I get the following error..
> >
> > generateStubs:
> >     [mkdir] Created dir:
> > D:\san\works\checkouts\obj\test\generated\cpp\Calculator
> > Caught exception (org.apache.tools.ant.BuildException) while expanding
> cp:
> > D:\san\works\checkouts\obj\package\axis-c-1.4.0-Win32\lib\axis not
found.
> >
> > BUILD FAILED
> > D:\san\works\checkouts\head\ws-axis\c\build\buildTest.xml:29:
> > D:\san\works\check
> > outs\obj\package\axis-c-1.4.0-Win32\lib\axis not found.
> >
> > Total time: 2 seconds
> >
> > I suggest "<fileset dir="${dir.wsdl2ws}" includes="wsdl2ws.jar"/>" be
> > changed to "<fileset dir="${dir.classes}" includes="wsdl2ws.jar"/>" in
> > buildTest.xml,  which gets rid of this error.
> >
> > Looks like when package.xml is run the binary and source distributions
> have
> > a -bin and -src appended so ${dir.wsdl2ws} fails. Is it ok to do this
> > change?
> >
> > sanjaya.
> >
> >
>
>



Mime
View raw message