axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fred Preston (JIRA)" <axis-c-...@ws.apache.org>
Subject [jira] Commented: (AXISCPP-373) To change the names of the Channel and Channel_ssl properties to include a http reference
Date Tue, 11 Jan 2005 13:25:13 GMT
     [ http://issues.apache.org/jira/browse/AXISCPP-373?page=comments#action_57505 ]
     
Fred Preston commented on AXISCPP-373:
--------------------------------------

Changing the following:-
Channel     -->> Channel_HTTP
Channel_ssl -->> Channel_HTTP_SSL

Adding the following:-
SecureInfo

> To change the names of the Channel and Channel_ssl properties to include a http reference
> -----------------------------------------------------------------------------------------
>
>          Key: AXISCPP-373
>          URL: http://issues.apache.org/jira/browse/AXISCPP-373
>      Project: Axis-C++
>         Type: Improvement
>  Environment: n/a
>     Reporter: Fred Preston
>     Assignee: Fred Preston

>
> +1
> IMHO it is better to use HTTP instead of http and SSL for ssl.
> Thanks,
> Samisa...
> On 06 Jan 2005 16:53:43 +0600, Roshan Weerasuriya <roshan@opensource.lk> wrote:
> > hi Fred,
> > 
> > +1
> > 
> > Roshan
> > On Thu, 2005-01-06 at 16:47, Fred Preston wrote:
> > >
> > >
> > > Hi All,
> > >       Looking into the future, are we happy with the naming conventions we
> > > currently have to identify the components within axiscpp.conf?  I was
> > > thinking specifically about what happens if we develop another transport?
> > > The name for the http transport is 'Transport_http' (which is probably
> > > fine), but the name for an http implemented ssl channel is 'Channel_ssl'
> > > and I want to define a non-secure http channel dll, i.e. 'Channel'.  Now we
> > > may want to reuse these names for different transports, therefore what I'm
> > > suggesting is that we make a more transport specific distinction for the
> > > channel implementations.  Thus:-
> > >
> > > 'Channel_ssl'     becomes 'Channel_http_ssl' and
> > > 'Channel'   becomes 'Channel_http'.
> > >
> > > Any thoughts?
> > >
> > > Regards,
> > >
> > > Fred Preston.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


Mime
View raw message