axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Perry2 <PERR...@uk.ibm.com>
Subject Re: problem with running ant tests
Date Fri, 28 Jan 2005 12:51:41 GMT
That's strange because the dynamicCode tag should mean that it should look
in the dynamicCodeDirectory for the source and not use the testCode
property.
Please can you confirm that you have the latest ant scripts in the
ws-axis/c/build directory.

In the latest version  line 49 is a blank line so shouldn't error which
makes me think it is not the latest version.

Regards,

Andrew Perry
IBM Web Services Client for C/C++
perryan@uk.ibm.com
Mail Point 127
IBM UK Laboratories. Hursley Park, Winchester, Hants. SO21 2JN
Tel. Internal 249828  External + 44 (0)1962 819828
Fax. + 44(0)1962 818080

"sanjaya singharage" <sanjayas@opensource.lk> wrote on 28/01/2005 12:29:29:

> yep. the culprit is DynamicTest01.xml the contents of which are as
follows
>
> <test>
>     <name>DynamicTest1</name>
>     <description>CalculatorDoc</description>
>  <dynamicCode>true</dynamicCode>
>  <dynamicCodeDirectory>Test01</dynamicCodeDirectory>
>     <clientLang>cpp</clientLang>
>     <wsdl>CalculatorDoc.wsdl</wsdl>
>     <expected>
>         <output>
>             DynamicTest01.expected
>         </output>
>     </expected>
>  <endpoint>http://localhost:80/Calculator/services/Calculator</endpoint>
> </test>
>
> what are the parameters..
>  <dynamicCode>true</dynamicCode>
>  <dynamicCodeDirectory>Test01</dynamicCodeDirectory>
> ?
> I renamed this file so that I could continue with the rest of the tests.
>
> sanjaya.
>
> ----- Original Message -----
> From: "Andrew Perry2" <PERRYAN@uk.ibm.com>
> To: "Apache AXIS C Developers List" <axis-c-dev@ws.apache.org>
> Cc: "Apache AXIS C Developers List" <axis-c-dev@ws.apache.org>
> Sent: Friday, January 28, 2005 6:14 PM
> Subject: Re: problem with running ant tests
>
>
> > The test property file for the test being run is missing a
> > <clientCode>whatever.cpp</clientCode> entry.
> > please check the relevant property file in the
> > ws-axis/c/tests/auto_build/testcases/tests directory to make sure it is
> > complete.
> >
> > Andrew Perry
> > IBM Web Services Client for C/C++
> > perryan@uk.ibm.com
> > Mail Point 127
> > IBM UK Laboratories. Hursley Park, Winchester, Hants. SO21 2JN
> > Tel. Internal 249828  External + 44 (0)1962 819828
> > Fax. + 44(0)1962 818080
> >
> > "sanjaya singharage" <sanjayas@opensource.lk> wrote on 28/01/2005
> 11:32:53:
> >
> > > I get this error when running ant -f text.xml .......
> > >
> > > BUILD FAILED
> > > D:\automatedaxiscpp\checkout\ws-axis\c\build\buildTest.xml:49:
Warning:
> > > Could no
> > > t find file
> > > D:\automatedaxiscpp\checkout\ws-axis\c\tests\auto_build\testcases\cl
> > > ient\cpp\${testCode} to copy.
> > >
> > > can anyone give me a quick solution?
> > >
> > > sanjaya.
> > >
> > >
> >
> >
> >
>
>


Mime
View raw message