axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anuradha Ratnaweera <gnu.slash.li...@gmail.com>
Subject Re: [Axis2] Dealing with different versions of automake/atoconf
Date Tue, 06 Dec 2005 04:13:37 GMT
On 12/6/05, Samisa Abeysinghe <samisa.abeysinghe@gmail.com> wrote:
>
> Given your expertise in the GNU make system, do you have any idea if
> we can make our configure.ac work across different versions of
> automake/autoconf?
>
> Basically the problem is that PHP uses autoconf 2.13 and automake
> 1.5 (PHP make system complains if the versions are not 2.13/1.5)
>
> Ours make use of autoconf 2.59 and automake 1.9 (our make system
> fails if versions are not 2.59/1.9)
>
> Can we write our configure.ac to work in these different version on
> auto tools?

I think the best option would be to find out the least common
denominator between the two different tools combination and remove the
version dependancy _completely_.  We don't have to be very much
backword compatible for anything earlier than 2.13/1.5.

What are the reasons to mandate 2.59/1.9?

      Anuradha
--
http://anuradha-ratnaweera.blogspot.com
http://www.linux.lk/~anuradha/

Mime
View raw message