axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Hawkins <HAWKI...@uk.ibm.com>
Subject Re: Using generated CPP files in visual studio 2003
Date Wed, 04 Jan 2006 11:55:19 GMT
OK, so this is a simple config problem.

The library you point the conf file is what is looked for e.g. if you set 
the file to c:\mypath\AxisXMLXercesParser_D then this equates to ->
m_LibHandler = PLATFORM_LOADLIB(c:\mypath\AxisXMLXercesParser_D);
So I suggest that you fully qualify the libs in the conf file.

Secondly

If you do "dumpbin /dependents" on the axisxmlxercesparser_d file what 
does it show you - is it the same version of xerces as is in your path (it 
should be if you've built it yourself). You need to make sure that this 
dll is in your PATH.

That should do it. If it doesn't then can you cut and paste the conf file 
that you have.

cheers,
John.








Henrik Grankvist <henrik.grankvist@gmail.com> 
04/01/2006 11:31
Please respond to
"Apache AXIS C Developers List"


To
Apache AXIS C Developers List <axis-c-dev@ws.apache.org>
cc

Subject
Re: Using generated CPP files in visual studio 2003






You were right, it is the xerces libraries that can't be loaded. 

I then set the AXISCPP_DEPLOY environment variable to a directory that 
contains a axiscpp.conf file. In this file I have specified all kinds of 
values for the XMLParser: attribute. Both just using the name 
"AxisXMLXercesParser_D", which was built by the ant script. In this case 
the I am certain that the dll was situated in the PATH variable. 

I then tried to point directly to the file using the whole path e.g. 
"C:\dotnetprojects\axis-c\AxisXMLXercesParser_D.dll" this didn't work 
either. As of now I'm clueless on what that could be the problem. When I 
debug the code I get to this point in the code:

int XMLParserFactory::loadLib()
{
    m_LibHandler = PLATFORM_LOADLIB(m_pcLibraryPath);
.
.
.

here m_LibHandler becomes nothing meaning that the library wasn't found. 

kind regards
Henrik

On 1/3/06, Henrik Grankvist <henrik.grankvist@gmail.com> wrote:
Well i have tried both the bin and the lib directory as additional lib 
directory for the project. Neither works. 

I'm not using a specific config file, I set the properties inside visual 
studio on the project. Furthermore I have copied the axis dlls  to the 
directory. 

I have added the xerces\bin directory to PATH but that didn't change 
anything. 


BTW I successfully built the libraries using ant. I will tomorrow debug a 
little more to see what is causing the crash. 


/Henrik


On 1/3/06, John Hawkins <HAWKINSJ@uk.ibm.com > wrote:

This sounds like you don't have the lib paths set up right. Do you use a 
configuration file? If so, are you sure that the axis dll's are in the 
places you have specified? Also, are you sure that the xerces libraries 
are in the PATH and that they are of version 2.2.0 





Henrik Grankvist <henrik.grankvist@gmail.com > 
03/01/2006 13:40 


Please respond to
"Apache AXIS C Developers List"


To
Apache AXIS C Developers List <axis-c-dev@ws.apache.org> 
cc

Subject
Re: Using generated CPP files in visual studio 2003








I beleive so to. 

I downloaded 1.5 of the code i.e. current on the homepage for axis-c. 

I then created the stub files in c++ using wsdl2ws. Then I built my 
console program to test the stub. It compiles fine but when running it, it 
crashes giving the following error "Unhandled exception at 0x7c901230 in 
axis-c.exe: User breakpoint."

When I debug I find out that it is when calling the constructor of Stub 
that makes everything crash. Which means that the debugger doesn't even 
get into the constructor of SimpleWSIF in the example below. 

SimpleWSIF::SimpleWSIF()
:Stub(" ", APTHTTP1_1)
{
   m_pCall->setEndpointURI("REPLACE_WITH_ACTUAL_URL");
} 



In the properties for the project I have specified the following:

additional include dirs: <xercesc_install>\include 
<axis-c_install>\include

Linker directives
General --> Additional Library Directories: <axis-c_install>\bin (because 
here an AxisClient.lib resides)
Input --> Additional Dependencies: AxisClient.lib

The dll AxisClient.dll is available in my programdir as well as 
AxisXMLParserXerces.dll HTTPChannel.dll and HTTPTransport.dll.

Perhaps I'm missing something. 

Because of the problems above I would like to build the libraries in debug 
mode so that I perhaps can find out what is causing the unknown exception 
to occur. 

/Henrik


On 1/3/06, John Hawkins <HAWKINSJ@uk.ibm.com > wrote: 

I think we might be better not building the code at all and concentrating 
on getting the client problems fixed using a binary release. 

What is the problem you're having with the client? What version of the 
code are you using? 

If you still want to build the code then I suggest you do it using ANT - 
which we support far better than in msvc directly (it uses the msvc 
compiler underneath). instructions here -> 
http://ws.apache.org/axis/cpp/antbuild-guide.html 




Henrik Grankvist < henrik.grankvist@gmail.com > 
03/01/2006 12:21 

Please respond to
"Apache AXIS C Developers List"



To
Apache AXIS C Developers List <axis-c-dev@ws.apache.org > 
cc

Subject
Re: Using generated CPP files in visual studio 2003










I checked out the code from svn now and tried to compile the distribution 
solution in vs 7.0 .... It does not work, first it complaints that 
libexpat.lib cannot be found. When removing this from the properties of 
the project and adding xercesc instead the linker gives the follwing 
error: 

AxisClient fatal error LNK1104: cannot open file '.\CDebug\apr_base64.obj'

I believe there is something wrong with the solutionfiles that makes them 
impossible to run on VS 7.0, unfortunately I don't have  access to VS 6.0 
right now. Do you have any suggestions on how to get things working? 

I must point out that my main problem is that I cannot run the compiled 
code for my generated clients,  it just crashes.

kind regards
Henrik



On 1/3/06, John Hawkins <HAWKINSJ@uk.ibm.com > wrote: 

do you mean cvs or svn? The latest code is in svn -> 
http://ws.apache.org/axis/cpp/developers-guide.html#checkingOut 


Henrik Grankvist < henrik.grankvist@gmail.com> 
03/01/2006 10:31 

Please respond to
"Apache AXIS C Developers List"



To
axis-c-dev@ws.apache.org 
cc

Subject
Using generated CPP files in visual studio 2003












Hello!

I'm having serious trouble using my ws client that is generated with
the wsdl2ws tool. There are no problems compiling and linking however
when running the program it just crashes giving me the following
exception:

Unhandled exception at 0x7c901230 in axis-c.exe: User breakpoint.

Then i thought I'd build the axisclient dll from the axis-c source.
However this doesn't work either the linker says that it can't find
the AxisException.obj file. When looking att the source, the source
file for this isn't anywhere to be found. Not even when I fetched the
whole project from cvs this file can be found.

Could someone here maybe help me? It's frustrating because I need to
get this to work soon.

kind regards
Henrik






Mime
View raw message