axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Clifford Audinet (JIRA)" <>
Subject [jira] Commented: (AXIS2C-519) [Axis2] axis2_svc_client_create_for_dynamic_invocation returns NULL
Date Tue, 04 Sep 2007 11:57:10 GMT


Clifford Audinet commented on AXIS2C-519:

Well that is certainly disappointing.  Thanks for letting me know, 
though...I do appreciate it.


Clifford Audinet
Software Architect

Stonebranch, Inc.
950 North Point Parkway
Suite 200
Alpharetta, Ga 30005
(678) 366-7887 X316

> [Axis2] axis2_svc_client_create_for_dynamic_invocation returns NULL
> -------------------------------------------------------------------
>                 Key: AXIS2C-519
>                 URL:
>             Project: Axis2-C
>          Issue Type: Bug
>          Components: core/clientapi
>    Affects Versions: 0.96
>         Environment: axis2c v0.96 win binaries
> WinXP Pro SP2
> WinAMD (Athalon X2 3800, 1GB RAM)
> MS Visual C++ 6.0 
>            Reporter: Clifford Audinet
> I am attempting to create a C web services client capable of dynamic invocation using
the Axis2C framework and have run into the following issue described below.
> The Problem:
> I modified the dynamic_client example to take all of the arguments
> related to dynamic invocation (WSDL file, namespace, service URL,
> operation, operation parameters, etc) from the command line and tested
> it using the Calculator example and it worked.
> When I changed the command line arguments to point to a remote service I started getting
errors when the service client was being created.  I tried a couple of different things but
got the same result.  Here's what I'm passing in:
> axis2_svc_client_create_for_dynamic_invocation(
> env,                                       //the usual pointer to an environment variable
> config_stx,                           //In the example this is NULL, but the docs said
it should be a pointer to a configuration I created one, although it's empty
> wsdl_uri,                              //The URI to the WSDL file which, based on the
>                                                  C:\axis2c\bin\samples\resources\jirasoapservice-v2.wsdl
> wsdl_svc_qname              //The service qname which, based on the output of AXIS2_QNAME_TO_STRING,
>                                                  JiraSoapServiceService|
> progParams->ws_name //The web service name: "JiraSoapServiceService"
> client_home                       //The axis2c deploy location "C:\axis2c"
> );
> Note for wsdl_uri:  I had switched to a local WSDL URI but I got the same result regardless.
 The remote WSDL URI was:
> The return from the function is, unfortunately, NULL (0x00000000).
> Sometimes it goes into the error block and sometimes it results in an
> unhandled exception in the AXIS_ENGINE.DLL: 0x00000005: Access Violation  .  I switched
back to the original example and it still works.
> I have changed the log output to DEBUG for logger but I don't see any difference in the
output in the log file.  I also tried to get the error code from the env variable but the
Access Violation error terminates the program.
> So why do values for a local service work but not a remote service?
> Please let me know what additional clarification or information you require and I will
supply it via this issue.
> Thanks,
> Cliff 

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message