axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dave Meier (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AXIS2C-941) IIS Module: fails with large data element
Date Wed, 30 Jan 2008 00:26:39 GMT

     [ https://issues.apache.org/jira/browse/AXIS2C-941?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dave Meier updated AXIS2C-941:
------------------------------

    Attachment: aewebservicesaxis70.wsdl

The call I am making is CreateFileAttachment (see in the attached wsdl).

The request looks like:

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing"
xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd"
xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">
  <soap:Header>
    <wsa:Action></wsa:Action>
    <wsa:MessageID>urn:uuid:780c518c-6056-4f84-af21-0552f856a6fd</wsa:MessageID>
    <wsa:ReplyTo>
      <wsa:Address>http://schemas.xmlsoap.org/ws/2004/08/addressing/role/anonymous</wsa:Address>
    </wsa:ReplyTo>
    <wsa:To>http://localhost/axis2/services/aewebservices70</wsa:To>
    <wsse:Security>
      <wsu:Timestamp wsu:Id="Timestamp-e17217ea-4d66-4ba9-8a7f-7f4239ab9265">
        <wsu:Created>2008-01-29T22:43:02Z</wsu:Created>
        <wsu:Expires>2008-01-29T22:48:02Z</wsu:Expires>
      </wsu:Timestamp>
    </wsse:Security>
  </soap:Header>
  <soap:Body>
    <CreateFileAttachment xmlns="urn:aewebservices70">
      <auth>
        <userId>joe</userId>
        <password />
        <hostname xsi:nil="true" />
      </auth>
      <itemID>1000:42</itemID>
      <attachmentContents>
        <name>TeamTrack Change Management</name>
        <fileName>tt.pdf</fileName>
        <showAsImage>true</showAsImage>
        <modificationDateTime>2008-01-29T14:43:01.2138881-08:00</modificationDateTime>
        <url xsi:nil="true" />
        <accessType>ATTACHACCESS-DEFAULT</accessType>
        <checksum>59215</checksum>
        <encodedContents>JVBERi0xLjQNJeL...Q0KJSVFT0YNCg==</encodedContents>
      </attachmentContents>
    </CreateFileAttachment>
  </soap:Body>
</soap:Envelope>

I replaced the middle of the large "encodedContents" value with "..." to avoid cluttering
this issue.

> IIS Module: fails with large data element
> -----------------------------------------
>
>                 Key: AXIS2C-941
>                 URL: https://issues.apache.org/jira/browse/AXIS2C-941
>             Project: Axis2-C
>          Issue Type: Bug
>          Components: transport/http
>    Affects Versions: Current (Nightly)
>         Environment: Windows XP, IIS 5.1
>            Reporter: Dave Meier
>            Priority: Blocker
>         Attachments: aewebservicesaxis70.wsdl
>
>
> I have a web service that takes the following as input.  Here is the wsdl:
>   <complexType name="FileAttachmentContents">
>    <complexContent>
>     <extension base="ae:FileAttachment">
>      <sequence>
>      <element name="checksum" type="xsd:long" minOccurs="1" maxOccurs="1"/>
>      <element name="encodedContents" type="xsd:base64Binary" minOccurs="1" maxOccurs="1"
nillable="false"/>
>      </sequence>
>     </extension>
>    </complexContent>
>   </complexType>
> With the axis2_http_server.exe it works fine with a 163KB file, where the contents of
the file are written in base64 into the "encodedContents" element.  But when I run the IIS
module and run the same client test, I get back an error saying that the "encodedContents"
element is NULL.
> I tried a 1KB file with the IIS module and that worked great.  So there appears to be
something limiting the sending of a large element when using the IIS module.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-dev-help@ws.apache.org


Mime
View raw message