axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Senaka Fernando" <sen...@wso2.com>
Subject RE: [jira] Commented: (AXIS2C-1043) Rampart/C module fails to load when running in IIS
Date Thu, 06 Mar 2008 19:53:29 GMT
Hi Dave,

I'm trying it with VS2005. Still no luck over here either. :(. If I remove
Rampart from the modules directory everything works fine.

Regards,
Senaka

> Still no luck.  Tried building and using openssl, axis2c and rampartc
> with /MT (VS 2003).
>
> -Dave.
>
> -----Original Message-----
> From: Dave Meier [mailto:DMeier@SERENA.com]
> Sent: Thursday, March 06, 2008 10:39 AM
> To: Apache AXIS C Developers List
> Subject: RE: [jira] Commented: (AXIS2C-1043) Rampart/C module fails to
> load when running in IIS
>
> Hi Senaka,
>
> Yeah I just realized I forgot to use an MT version of openssl.  I am now
> building that.  I put the openssl dlls directly into the lib directory
> of axis/c when I run.
>
> Thanks,
>
> -Dave.
>
> -----Original Message-----
> From: Senaka Fernando (JIRA) [mailto:jira@apache.org]
> Sent: Thursday, March 06, 2008 10:35 AM
> To: axis-c-dev@ws.apache.org
> Subject: [jira] Commented: (AXIS2C-1043) Rampart/C module fails to load
> when running in IIS
>
>
>     [
> https://issues.apache.org/jira/browse/AXIS2C-1043?page=com.atlassian.jir
> a.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=1257582
> 2#action_12575822 ]
>
> Senaka Fernando commented on AXIS2C-1043:
> -----------------------------------------
>
> Hi Dave,
>
> Is {OpenSSL_BIN_DIR}\lib\VC\static on your PATH environment variable?
> Anyway, I will check this issue on my machine and let you know.
>
> Regards,
> Senaka
>
>> Rampart/C module fails to load when running in IIS
>> --------------------------------------------------
>>
>>                 Key: AXIS2C-1043
>>                 URL: https://issues.apache.org/jira/browse/AXIS2C-1043
>>             Project: Axis2-C
>>          Issue Type: Bug
>>          Components: core/transport
>>    Affects Versions: Current (Nightly)
>>         Environment: Windows XP, IIS 5.1
>>            Reporter: Dave Meier
>>
>> I am using Rampart/C and Axis2/C and I cannot get it to work when
> running in IIS.  Everything works fine when running from the
> axis2_http_server.exe but fails when I use IIS.
>> The Rampart module is failing to load and I am not sure why.  I traced
> it to the LoadLibrary call failing.  I have rebuilt both Axis2/C and
> Rampart/C several times and checked all the settings.  I am not sure why
> it is not loading.
>> [Wed Mar 05 17:49:21 2008] [debug] ..\..\src\core\engine\phase.c(121)
>> axis2_handler_t *request_uri_based_dispatcher added to the index 0 of
>> the phase Transport [Wed Mar 05 17:49:21 2008] [debug]
>> ..\..\src\core\engine\phase.c(121) axis2_handler_t
>> *addressing_based_dispatcher added to the index 1 of the phase
>> Transport [Wed Mar 05 17:49:21 2008] [debug]
>> ..\..\src\core\engine\phase.c(121) axis2_handler_t *rest_dispatcher
>> added to the index 0 of the phase Dispatch [Wed Mar 05 17:49:21 2008]
>> [debug] ..\..\src\core\engine\phase.c(121) axis2_handler_t
>> *soap_message_body_based_dispatcher added to the index 1 of the phase
>> Dispatch [Wed Mar 05 17:49:21 2008] [debug]
>> ..\..\src\core\engine\phase.c(121) axis2_handler_t
>> *soap_action_based_dispatcher added to the index 2 of the phase
>> Dispatch [Wed Mar 05 17:49:21 2008] [debug]
>> ..\..\src\core\engine\phase.c(121) axis2_handler_t
>> *dispatch_post_conditions_evaluator added to the index 0 of the phase
>> PostDispatch [Wed Mar 05 17:49:21 2008] [debug]
>> ..\..\src\core\engine\phase.c(121) axis2_handler_t *context_handler
>> added to the index 1 of the phase PostDispatch [Wed Mar 05 17:49:21
>> 2008] [debug] ..\..\src\core\deployment\conf_builder.c(233) no custom
>> dispatching order found continue with default dispatching order [Wed
>> Mar 05 17:49:21 2008] [debug]
>> ..\..\src\core\deployment\conf_builder.c(384) module addressing found
>> in axis2.xml [Wed Mar 05 17:49:21 2008] [debug]
>> ..\..\util\src\class_loader.c(141) Object loaded successfully [Wed Mar
>
>> 05 17:49:21 2008] [debug] ..\..\util\src\class_loader.c(141) Object
>> loaded successfully [Wed Mar 05 17:49:21 2008] [debug]
>> ..\..\src\core\deployment\repos_listener.c(93)
>> axis2_repos_listener_create_with_folder_name_and_dep_engine:
>> folder_name=F:/TeamTrack701/software/contrib/axis2c/Win32
>> [Wed Mar 05 17:49:21 2008] [debug]
>> ..\..\src\core\deployment\repos_listener.c(103)
>> axis2_repos_listener_create_with_folder_name_and_dep_engine: after
>> axis2_repos_listener_create [Wed Mar 05 17:49:21 2008] [debug]
>> ..\..\src\core\deployment\repos_listener.c(115)
>> axis2_repos_listener_create_with_folder_name_and_dep_engine: after
>> axis2_dep_engine_get_file_flag [Wed Mar 05 17:49:21 2008] [debug]
>> ..\..\src\core\deployment\repos_listener.c(123)
>> axis2_repos_listener_create_with_folder_name_and_dep_engine: after
>> axis2_ws_info_list_create_with_dep_engine
>> [Wed Mar 05 17:49:21 2008] [debug]
>> ..\..\src\core\deployment\repos_listener.c(137)
>> axis2_repos_listener_create_with_folder_name_and_dep_engine: after
>> axis2_dep_engine_get_axis_conf [Wed Mar 05 17:49:21 2008] [debug]
>> ..\..\src\core\deployment\repos_listener.c(147)
>> axis2_repos_listener_create_with_folder_name_and_dep_engine: after
>> axis2_repos_listener_set_conf [Wed Mar 05 17:49:21 2008] [debug]
>> ..\..\src\core\deployment\dep_engine.c(1259)
>> axis2_dep_engine_load_module_dll: DLL path is :
>> F:/TeamTrack701/software/contrib/axis2c/Win32/modules/addressing/axis2
>> _mod_addr.dll [Wed Mar 05 17:49:21 2008] [debug]
>> ..\..\util\src\class_loader.c(141) Object loaded successfully [Wed Mar
>
>> 05 17:49:21 2008] [debug] ..\..\src\core\deployment\dep_engine.c(1259)
>
>> axis2_dep_engine_load_module_dll: DLL path is :
>> F:/TeamTrack701/software/contrib/axis2c/Win32/modules/logging/axis2_mo
>> d_log.dll [Wed Mar 05 17:49:21 2008] [debug]
>> ..\..\util\src\class_loader.c(141) Object loaded successfully [Wed Mar
>
>> 05 17:49:21 2008] [debug] ..\..\src\core\deployment\dep_engine.c(1259)
>
>> axis2_dep_engine_load_module_dll: DLL path is :
>> F:/TeamTrack701/software/contrib/axis2c/Win32/modules/rampart/mod_ramp
>> art.dll [Wed Mar 05 17:49:21 2008] [debug]
>> ..\..\util\src\class_loader.c(80) axutil_class_loader_load_lib failed:
>
>> F:/TeamTrack701/software/contrib/axis2c/Win32/modules/rampart/mod_ramp
>> art.dll [Wed Mar 05 17:49:21 2008] [debug]
>> ..\..\src\core\deployment\repos_listener.c(153)
>> AXIS2_ERROR_REPOS_LISTENER_INIT_FAILED
>> [Wed Mar 05 17:49:21 2008] [error]
>> ..\..\src\core\deployment\dep_engine.c(768) dep_engine repos listener
>> creation failed, folder name is
>> F:/TeamTrack701/software/contrib/axis2c/Win32
>> [Wed Mar 05 17:49:21 2008] [error]
>> ..\..\src\core\deployment\conf_init.c(67) dep engine load failed. conf
>
>> value is NULL
>
> --
> This message is automatically generated by JIRA.
> -
> You can reply to this email to add a comment to the issue online.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-c-dev-help@ws.apache.org
>
>
> **********************************************************************
> This email and any files transmitted with it are confidential and
> intended solely for the use of the individual or entity to whom they are
> addressed. Any unauthorized review, use, disclosure or distribution is
> prohibited. If you are not the intended recipient, please contact the
> sender by reply e-mail and destroy all copies of the original message.
> **********************************************************************
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-c-dev-help@ws.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-c-dev-help@ws.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-dev-help@ws.apache.org


Mime
View raw message