axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "T. P. Saravanan" <s...@procsys.com>
Subject wrong braces in samples/configure.ac?
Date Sun, 05 Jul 2009 15:52:44 GMT

I feel the braces are wrong in some places in samples/configure.ac.
Diffs below.  Somebody with more autoconf knowledge merge it, if
appropriate.

---

Index: samples/configure.ac
===================================================================
--- samples/configure.ac	(revision 791255)
+++ samples/configure.ac	(working copy)
@@ -85,7 +85,7 @@
  [  --with-axis2[=PATH]     Find the AXIS2 header files in 'PATH'.
      'PATH' should point to AXIS2 include files location.
      If you omit the '=PATH' part completely, the configure script will 
search
-    '$(AXIS2C_HOME)/include/axis2-1.6.0' for AXIS2 headers.],
+    '${AXIS2C_HOME}/include/axis2-1.6.0' for AXIS2 headers.],
  [ case "$withval" in
    no)
      AC_MSG_RESULT(no)
@@ -95,9 +95,9 @@
      dnl Find axiom include dir in the path
      if test -d $withval; then
          axis2inc="-I$withval"
-    dnl else find the axiom include dir in $(AXIS2C_HOME)/include
-    elif test -d '$(AXIS2C_HOME)/include'; then
-        axis2inc="-I$(AXIS2C_HOME)/include/axis2-1.6.0"
+    dnl else find the axiom include dir in ${AXIS2C_HOME}/include
+    elif test -d '${AXIS2C_HOME}/include'; then
+        axis2inc="-I${AXIS2C_HOME}/include/axis2-1.6.0"
      else
          AC_MSG_ERROR(could not find axis2. stop)
      fi


---

Regards,
Saravanan.

Mime
View raw message