axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Cosmo <pco...@incognito.com>
Subject error: Could not map the MEP URI ...
Date Sat, 18 Jul 2009 00:58:47 GMT
When I send a soap message that contains an xml Date value, the axis2/c service throws the
exception "Data element of the OM Node is NULL", and logs the following:

[Fri Jul 17 20:50:01 2009] [error] ..\..\src\core\description\op.c(833) Could not map the
MEP URI http://www.w3.org/ns/wsdl/in-out to an Axis2/C MEP constant value in retrieving MEP
for operation login
[Fri Jul 17 20:50:01 2009] [error] c:\code\incognito\dhcp-test\svc\src\incowsdlsecurity\gensrc\adb_login.c(472)
failed in building element loginTime
[Fri Jul 17 20:50:01 2009] [error] c:\code\incognito\dhcp-test\svc\src\incowsdlsecurity\gensrc\adb_login.c(489)
failed in setting the value for loginTime


Anyone have ideas what causes this error and how I can get rid of it? It is a java client
sending the message and the funny thing is that if I compile the wsdl into java code using
wsimport.exe tool from the command line I don't get the error, but if I generate the code
using an ant task (com.sun.tools.ws.ant.WsImport) I do get the error.

Any insights?

thanks,
Patrick Cosmo

Incognito Software Inc.
Senior Software Design Engineer
T: +1(604)678-2855
F: +1(604)688-4339
E: pcosmo@incognito.com<mailto:pcosmo@incognito.com>
www.incognito.com<http://www.incognito.com/>





Mime
View raw message