axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Cosmo <pco...@incognito.com>
Subject axis2c doesn't work with clients using latest jdk?
Date Sat, 18 Jul 2009 01:22:23 GMT
I reported a problem earlier about "MEP URI" stuff, but I've narrowed this problem down a little
further.

If I generate client java code using the 1.6.01 jdk wsimport tool (jdk1.6.0_01/bin/wsimport),
then the AXIS2C service can parse it all and respond correctly - everything works fine.

However, if I use the latest JDK (jdk1.6.0_13/bin/wsimport), then I get the following problems:

When I send a soap message that contains an xml Date value, the axis2/c service throws the
exception "Data element of the OM Node is NULL", and logs the following:

[Fri Jul 17 20:50:01 2009] [error] ..\..\src\core\description\op.c(833) Could not map the
MEP URI http://www.w3.org/ns/wsdl/in-out to an Axis2/C MEP constant value in retrieving MEP
for operation login
[Fri Jul 17 20:50:01 2009] [error] c:\code\incognito\dhcp-test\svc\src\incowsdlsecurity\gensrc\adb_login.c(472)
failed in building element loginTime
[Fri Jul 17 20:50:01 2009] [error] c:\code\incognito\dhcp-test\svc\src\incowsdlsecurity\gensrc\adb_login.c(489)
failed in setting the value for loginTime

Anyone know anything about this?

thanks,
Patrick Cosmo

Incognito Software Inc.
Senior Software Design Engineer
T: +1(604)678-2855
F: +1(604)688-4339
E: pcosmo@incognito.com<mailto:pcosmo@incognito.com>
www.incognito.com<http://www.incognito.com/>





Mime
View raw message