axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Leland" <st...@pouchapond.com>
Subject ssl on win2k8
Date Wed, 03 Feb 2010 22:24:47 GMT
I am trying to get 2 axis2_http_servers, both version 1.6.0 and running on 
different win2k8 boxes, to converse exclusively over ssl as nicely as they 
do over http.  Unfortunately nothing happens... any help on how to figure 
out what I've done wrong would be great apreciated!!

When I point a browser to one the services, using https, the request never 
completes.  All I see in the logs are messages like this:
[Wed Feb 03 16:35:49 2010] [error] 
..\..\src\core\transport\http\common\http_request_line.c(117) Invalid status 
line or invalid request line
[Wed Feb 03 16:35:49 2010] [error] 
..\..\src\core\transport\http\common\simple_http_svr_conn.c(161) Invalid 
status line or invalid request line
[Wed Feb 03 16:35:49 2010] [error] 
..\..\src\core\transport\http\receiver\http_svr_thread.c(260) Could not 
create request

No matter what value I set for the ssl port, the only port netstat shows 
being open is 9090.  That's even when I have both http and https defined in 
the axis2.xml - can http and https use the same port?

I just tried the same tests with a build of today's trunk, and get the same 
results - so I must be doing something wrong.  I am building with openssl 
set in build\win32\configure.in, and have also tried using libcurl with no 
impact.  At the moment I am trying to eliminate possible culprits and so not 
building with libcurl.

TIA for any advice!
Steve

My Axis2.xml:
<axisconfig name="Axis2/C">
    <!-- Enable REST -->
    <parameter name="enableREST" locked="false">false</parameter>

    <transportReceiver name="https" class="axis2_http_receiver">
        <parameter name="port" locked="false">6443</parameter>
        <parameter name="exposeHeaders" locked="true">false</parameter>
    </transportReceiver>

    <!-- Uncomment the following with appropriate parameters to enable the 
SSL transport sender.
         Also make sure that the appropriate transport receiver is enabled 
above.-->
    <transportSender name="https" class="axis2_http_sender">
      <parameter name="PROTOCOL" locked="false">HTTP/1.1</parameter>
      <parameter name="xml-declaration" insert="true"/>
    </transportSender>

 <parameter name="SERVER_CERT">server.cer</parameter>
 <parameter name="KEY_FILE">client.pem</parameter>

    <phaseOrder type="inflow">
        <!-- System pre defined phases       -->
        <phase name="Transport"/>
        <phase name="PreDispatch"/>
        <phase name="Dispatch"/>
        <phase name="PostDispatch"/>
    </phaseOrder>
    <phaseOrder type="outflow">
        <phase name="MessageOut"/>
    </phaseOrder>
    <phaseOrder type="INfaultflow">
        <!-- User defined phases could be added here -->
    </phaseOrder>
    <phaseOrder type="Outfaultflow">
        <phase name="MessageOut"/>
    </phaseOrder>
</axisconfig>




Mime
View raw message