axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "shawndeng (JIRA)" <j...@apache.org>
Subject [jira] Created: (AXIS2C-1505) encoding fault with axis2c
Date Wed, 24 Nov 2010 18:29:15 GMT
encoding fault with axis2c
--------------------------

                 Key: AXIS2C-1505
                 URL: https://issues.apache.org/jira/browse/AXIS2C-1505
             Project: Axis2-C
          Issue Type: Bug
          Components: REST
    Affects Versions: 1.6.0
         Environment: centos 5.4
            Reporter: shawndeng
             Fix For: 1.7.0


I setup axis2c and did not set any special parameter. Just built a simple RESTfull http post
service. When I test the service, if I use "GBK" as the encoding charset, axis server can
read chinese character correctly, but if I use "utf-8" or any other encoding, server side
can not read Chinese character.

I think the default encoding is "utf-8" and I am quite sure that I didn't set any parameter
related to character encoding. So why I have to set the encoding to "GBK" in the client side?

My project demand us to use "utf-8" as the encoding charset. Can you help me on this issue
or give me some suggestions? I want to know how to set up encoding charset in axis2c.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: c-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: c-dev-help@axis.apache.org


Mime
View raw message