axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Mantaut (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AXIS2C-1610) Error while building with ./configure --enable-tests=yes
Date Sat, 10 Nov 2012 18:23:12 GMT
Alex Mantaut created AXIS2C-1610:
------------------------------------

             Summary: Error while building with ./configure --enable-tests=yes
                 Key: AXIS2C-1610
                 URL: https://issues.apache.org/jira/browse/AXIS2C-1610
             Project: Axis2-C
          Issue Type: Bug
          Components: build system
    Affects Versions: 1.6.0
         Environment: Linux
            Reporter: Alex Mantaut
             Fix For: 1.7.0


/usr/bin/ld: note: 'axiom_xml_writer_get_xml' is defined in DSO /home/alexmantaut/tmp/axis-trunk/trunk2/axiom/src/parser/guththila/.libs/libaxis2_parser.so.0
so try adding it to the linker command line
/home/alexmantaut/tmp/axis-trunk/trunk2/axiom/src/parser/guththila/.libs/libaxis2_parser.so.0:
could not read symbols: Invalid operation
collect2: ld returned 1 exit status

Run ./configure --enable-tests=yes

libaxis2_parser seems to be missing from the linkers options for those tests...
Attached patch takes care of that.



--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: c-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: c-dev-help@axis.apache.org


Mime
View raw message