axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sanjay Bahal <sb6...@yahoo.com>
Subject Re: Axis Install Problem- Help!!
Date Sun, 02 Dec 2001 16:11:00 GMT
Glen,
I was once again looking at alpha2 version. The
GetQuote example, the code is:
// TESTING HACK BY ROBJ
      if (symbol.equals("XXX_noaction")) {
          symbol = "XXX";
          call.set(HTTPConstants.MC_HTTP_SOAPACTION,
"");
      }

      call.set( Transport.USER, opts.getUser() );
      call.set( Transport.PASSWORD, opts.getPassword()
);
String countOption = opts.isValueSet('c');
	  
      int count=1;
      if ( countOption != null) {
        count=Integer.valueOf(countOption).intValue();
        System.out.println("Iterating " + count + "
times");
      }
1.The piece of code XXX_noaction is incorrect- even if
I change to XXX it still does not work.
2. I further see countOption = null. That should also
be cause of problem.
In any case. I would apprecaite help.
Thanks
Sanjay
--- Glen Daniels <gdaniels@macromedia.com> wrote:
> Hi Sanjay:
> 
> Your earlier problem with the deployment was that
> you were using the old URI
> (i.e. /axis/servlet/AxisServlet) instead of the new
> one
> (axis/services/AdminService) for deploying.  I'd
> recommend going back to the
> nightly build version and just removing the -l
> argument entirely from the
> deploy command line.  Also, you had mentioned
> deploying the "client_deploy"
> file, which probably isn't right for server-side
> deployment....
> 
> In any case, if you still have problems, please grab
> the XML trace (using
> tcpmon) of what's going across the wire, which
> usually clears things up - in
> the case you mention below, I'm guessing there's
> some kind of error
> accessing the servlet which is causing you to get
> HTML (instead of XML)
> back.
> 
> --Glen
> 
> ----- Original Message -----
> From: "Sanjay Bahal" <sb6325@yahoo.com>
> To: <axis-dev@xml.apache.org>
> Sent: Friday, November 30, 2001 12:11 PM
> Subject: Re: Axis Install Problem- Help!!
> 
> 
> > Hi,
> > Does any Axis Guru- getting a chance to look at
> this?
> > I need to get some kind of a protype going. So I
> would
> > appreciate any help.
> > I am on Tomact 4.01 on win2000 using xerces.
> > TIA
> > Sanjay
> > --- Sanjay Bahal <sb6325@yahoo.com> wrote:
> > > Hi all,
> > > I downloaded the alpha2 version instead of the
> > > nighly
> > > build- that I was using earlier. This has worked
> > > better. I could deploy.
> > > But I still can not execute(step 6):
> > > C:\xml-axis>java samples.stock.GetQuote
> > > -lhttp://localhost:8080/axis/servlet/Axi
> > > sServlet -uuser1 -wpass1 XXX
> > > AxisFault
> > > faultCode:
> > >
> http://xml.apache.org/axis/:Server.generalException
> > >   faultString: org.xml.sax.SAXParseException:
> The
> > > markup in the document preceding the root
> element
> > > must
> > > be well-formed.
> > > at
> > >
> >
>
org.apache.xerces.framework.XMLParser.reportError(XMLParser.java:1196)
> > > at
> > >
> >
>
org.apache.xerces.framework.XMLDocumentScanner.reportFatalXMLError(XMLDocume
> ntScanner.java:626)
> > > at
> > >
> >
>
org.apache.xerces.framework.XMLDocumentScanner$XMLDeclDispatcher.dispatch(XM
> LDocumentScanner.java:809)
> > > at
> > >
> >
>
org.apache.xerces.framework.XMLDocumentScanner.parseSome(XMLDocumentScanner.
> java:381)
> > > at
> > >
> >
>
org.apache.xerces.framework.XMLParser.parse(XMLParser.java:1081)
> > > at
> > >
> >
>
javax.xml.parsers.SAXParser.parse(SAXParser.java:374)
> > > at
> > >
> >
>
org.apache.axis.encoding.DeserializationContext.parse(DeserializationContext
> .java:160)
> > > at
> > >
> >
>
org.apache.axis.Message.getAsSOAPEnvelope(Message.java:319)
> > > at
> > >
> >
>
org.apache.axis.client.ServiceClient.invoke(ServiceClient.java:588)
> > > at
> > >
> >
>
org.apache.axis.client.ServiceClient.invoke(ServiceClient.java:494)
> > > at
> > >
> samples.stock.GetQuote.getQuote(GetQuote.java:120)
> > > at
> samples.stock.GetQuote.main(GetQuote.java:135)
> > > faultActor: null
> > > faultDetails: null
> > >
> > > Thanks a lot,
> > > Sanjay
> >
> >
> > __________________________________________________
> > Do You Yahoo!?
> > Yahoo! GeoCities - quick and easy web site
> hosting, just $8.95/month.
> > http://geocities.yahoo.com/ps/info1
> >
> 


__________________________________________________
Do You Yahoo!?
Buy the perfect holiday gifts at Yahoo! Shopping.
http://shopping.yahoo.com

Mime
View raw message