axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Russell Butek" <bu...@us.ibm.com>
Subject Re: WSDL2Java generates incorrect field reference (beta 2)
Date Wed, 01 May 2002 12:19:46 GMT
Are you sure you are using the beta2 jars?  There is no reference in the
latest AXIS codebase to PARAM_MODE_IN.

ParameterMode is a JAX-RPC-defined class.  Before version 0.8 the spec said
ParameterMode.PARAM_MODE_IN.  In 0.8 and beyond it says ParameterMode.IN.
AXIS beta 2 supports JAX-RPC 0.8 (AXIS beta 1 was somewhere between 0.6 and
0.7).  I believe Sun's EA2 supports 0.7.

JAX-RPC now has a 0.9 version and soon a 1.0 version, so don't be surprised
if there are more changes (though changes at this point are unlikely).
We're coding to a spec that's not even official, yet; the joys of living on
the bleeding edge.

Russell Butek
butek@us.ibm.com


Alan Moore <amoore@ciphergen.com> on 04/30/2002 05:40:38 PM

Please respond to axis-user@xml.apache.org

To:    "'axis-dev@xml.apache.org'" <axis-dev@xml.apache.org>,
       axis-user@xml.apache.org
cc:
Subject:    WSDL2Java generates incorrect field reference (beta 2)



After running WSDL2Java (beta2) against my wsdl file, the generated code
contains references to a non-existent field:

javax.xml.rpc.ParameterMode.PARAM_MODE_IN

I think this should be:

javax.xml.rpc.ParameterMode.IN

since the ParameterMode class in the xmlrpc.jar distributed with Axis beta2
has this (updated?) definition...

Either I am picking up the wrong .jar or the WSDL2Java compiler generates
the wrong code. Does anyone know what the correct name should be?

BTW - the ParameterMode class in the Sun Java Web Services Developer Pack
EA2 (jwsdp-1.0-ea2/common/lib/jaxrpc-api.jar) has the .PARAM_MODE_IN
attribute.

alan



Mime
View raw message