axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 14182] - Java2WSDL fails when processing java.lang.Object
Date Wed, 06 Nov 2002 17:18:33 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14182>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14182

Java2WSDL fails when processing java.lang.Object





------- Additional Comments From rcauble@motive.com  2002-11-06 17:18 -------
FYI - there's another symptom of this same defect. That is, if you have a 
service:

public class MyService
{
   public Object [] echoObjectArray(Object [] arr) {return arr;}
}

When interroperating with a .Net client, the .Net client will choke upon 
receiving the response:

"The specified type was not recognized: name='anyType', 
namespace='http://www.w3.org/1999/XMLSchema', at <multiRef xmlns=''>." 

That is because the response from Axis is this:
<multiRef id="id0" soapenc:root="0" 
soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" 
xsi:type="soapenc:Array" soapenc:arrayType="ns2:anyType[2]" 
xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/" 
xmlns:ns2="http://www.w3.org/1999/XMLSchema">

rather than this:
<multiRef id="id0" soapenc:root="0" 
soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" 
xsi:type="soapenc:Array" soapenc:arrayType="xsd:anyType[2]" 
xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/">

Mime
View raw message