axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jens Schumann <j...@void.fm>
Subject Re: what version of commons-discovery is being used in the latest version?
Date Thu, 27 Mar 2003 17:53:52 GMT
On 3/25/03 11:18 PM Eric.D.Friedman@WellsFargo.COM
<Eric.D.Friedman@WellsFargo.COM> wrote:

> Well, it's clear to me what's happening, for whatever that's worth.  I'm
> sure it's clear to Jens too, but I'll summarize it anyway for the benefit of
> the mail archives, if nothing else.  Also, there's a possible solution
> suggested below for Jens' specific problem.
> 
> <workaround>
> So, in the case of WSDDProvider, you must ensure that the classloader that
> loads WSDDProvider can "see" all of the implementations of that service you
> want to use.  If you put WSDDProvider into a parent classloader, your
> application's implementations will go undiscovered.
> </workaround>

This is possible as long as you don't use Weblogic, EJBs and a shared
archive containing all your custom classes ;(

Jens  





Mime
View raw message