axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume Sauthier <Guillaume.Sauth...@Objectweb.org>
Subject WSDL4J and Xerces 2.6.0 Incompatibility
Date Fri, 13 Feb 2004 12:03:08 GMT
Hello Guys

This week I was facing some weird problems using WSDL4J.
I was pointing to a local WSDL file, and when I used WSDLReader, It
fails with a WSDL_INVALID Exception !!
The cause of the failure was that a WSDLReader is waiting for a
wsdl:definition document element but the Document was a HTML document
!!?!!

Here is the Exception :
WSDLException (at /HTML): faultCode=INVALID_WSDL: Expected element
'{http://schemas.xmlsoap.org/wsdl/}definitions'.

I checked many time my wsdl and nowhere I found an HTML element!

After a while I found the root cause!
It was because of Xerces 2.6.0! When using xerces 2.6.1, parsing is OK
and WSDL4J no more fails ...

Conclusion :
Do not use xerces 2.6.0 with wsdl4j
Note : Ant 1.6.0 use xerces 2.6.0 ...

Regards

Guillaume

Mime
View raw message