axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From axis-...@ws.apache.org
Subject [jira] Created: (AXIS-1591) Migration from Axis 1.1 (or 1.2Beta)
Date Thu, 07 Oct 2004 02:25:52 GMT
Message:

  A new issue has been created in JIRA.

---------------------------------------------------------------------
View the issue:
  http://issues.apache.org/jira/browse/AXIS-1591

Here is an overview of the issue:
---------------------------------------------------------------------
        Key: AXIS-1591
    Summary: Migration from Axis 1.1 (or 1.2Beta)
       Type: Bug

     Status: Unassigned
   Priority: Major

    Project: Axis

   Assignee: 
   Reporter: Reiner Kappenberger

    Created: Wed, 6 Oct 2004 7:24 PM
    Updated: Wed, 6 Oct 2004 7:24 PM
Environment: JDK 1.4.2_04, Windows XP, JBoss

Description:
I'm trying to migrate to AXIS 1.2RC1 and the application which worked perfectly under 1.1
and 1.2Beta3 is suddenly not working any more.

The fragment in question is shown below:

response = fac.createMessage();

SOAPPart part = response.getSOAPPart();
SOAPEnvelope envelope = part.getEnvelope();
				envelope.addNamespaceDeclaration("cwmp", uri);
SOAPBody body = envelope.getBody();
SOAPHeader header = envelope.getHeader();

response = createHeader(response);
				
// Create SOAPBodyElement request 
Name bodyName =
					envelope.createName("InformResponse", "cwmp", uri);
SOAPBodyElement informResponseElement = 				body.addBodyElement(bodyName);

SOAPElement maxEnvelopesElement = 				informResponseElement.addChildElement(maxEnvelopesName);
maxEnvelopesElement.addTextNode("1");
response.saveChanges();

The message assembled before was:
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:cwmp="urn:dslforum-org:cwmp-1-0">
 <soapenv:Header>
  <cwmp:ID soapenv:mustUnderstand="1">1234</cwmp:ID>
 </soapenv:Header>
 <soapenv:Body>
  <cwmp:InformResponse xmlns:cwmp......>
   <MaxEnvelopes xmlns="">1</MaxEnvelopes>
 </soapenv:Body>
</soapenv:Envelope>

Now it comes up as:

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:cwmp="urn:dslforum-org:cwmp-1-0">
 <soapenv:Header>
  <cwmp:ID soapenv:mustUnderstand="1">1234</cwmp:ID>
 </soapenv:Header>
 <soapenv:Body/>
</soapenv:Envelope>




---------------------------------------------------------------------
JIRA INFORMATION:
This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa

If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


Mime
View raw message