axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Kador (JIRA)" <axis-...@ws.apache.org>
Subject [jira] Created: (AXIS-2018) WSDL2Java generates > symbols where it shouldn't
Date Thu, 26 May 2005 17:40:53 GMT
WSDL2Java generates > symbols where it shouldn't
------------------------------------------------

         Key: AXIS-2018
         URL: http://issues.apache.org/jira/browse/AXIS-2018
     Project: Axis
        Type: Bug
  Components: WSDL processing  
    Versions: 1.2    
 Environment: Windows XP w/ SP1, JBoss 4.0.2, Axis 1.2
    Reporter: Daniel Kador
 Attachments: StockQuote.wsdl, StockQuote.xsd, deploy.wsdd

First off, I was under the impression that this bug was fixed.  It's possible I'm doing something
incorrectly, but if so, I'm not sure what.  Hopefully I'm not wasting any developer's time.

I'm using a WSDL that has an .xsd file as its schema.  I'll attach them if requested.  When
I run the command "java org.apache.axis.wsdl.WSDL2Java -s -S true mywsdl.wsdl", everything
proceeds as it should.  However, both the deploy.wsdd and various parts of the emitted Java
code contains extraneous > symbols, which obviously is not a good thing.  Like I said above,
I thought this was fixed in the 1.2 release, but apparently it is not.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message