axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ronny Riedel (JIRA)" <axis-...@ws.apache.org>
Subject [jira] Updated: (AXIS-2055) AXIS 1.2 (final) - document/literal - error processing operation with 2 arguments
Date Thu, 23 Jun 2005 18:12:11 GMT
     [ http://issues.apache.org/jira/browse/AXIS-2055?page=all ]

Ronny Riedel updated AXIS-2055:
-------------------------------

    Attachment: second_parameter_is_null_by_rig.txt

> AXIS 1.2 (final) - document/literal - error processing operation with 2 arguments
> ---------------------------------------------------------------------------------
>
>          Key: AXIS-2055
>          URL: http://issues.apache.org/jira/browse/AXIS-2055
>      Project: Apache Axis
>         Type: Bug
>   Components: Serialization/Deserialization
>     Versions: 1.2
>  Environment: java full version "1.4.2_01-b06"
>     Reporter: Ephemeris Lappis
>  Attachments: axis3.wsdl, deploy.wsdd, http-request.txt, http-response.txt, second_parameter_is_null_by_rig.txt,
server-error.txt
>
> It seems an axis internal error occurs on the server side, using document/literal style,
when processing an operation with the following signature :
> 	public int testIntegerPairToInteger(int i1, int i2)
> The wsdl and wsdd files that are attached seem ok for me, and the sent request too.
> The error trace on the server side is also attached.
> Just for information, the same operation is processed without any problem in both wrapped
and document styles...
> I've done another test with an operation like
> 	CustomeType operation(CustomeType v1, CustomeType v2)
> And it seems the problem is similar. No error is produced, but the server class only
receives the first parameter, the second one is always null.
> The http request seems ok :
> POST /axis3/services/TestServicePort HTTP/1.0 Content-Type: text/xml; charset=utf-8 Accept:
application/soap+xml, application/dime, multipart/related, text/* User-Agent: Axis/1.2 Host:
127.0.0.1:81 Cache-Control: no-cache Pragma: no-cache SOAPAction: "" Content-Length: 689 
<?xml version="1.0" encoding="UTF-8"?>
>    <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
>       <soapenv:Body>
>          <in13 xmlns="urn:axis-test3">
>             <booleanProperty>true</booleanProperty>
>             <doubleProperty>13.0</doubleProperty>
>             <integerProperty>11</integerProperty>
>             <longProperty>12</longProperty>
>             <stringProperty>a</stringProperty>
>          </in13>
>          <in14 xmlns="urn:axis-test3">
>             <booleanProperty>true</booleanProperty>
>             <doubleProperty>23.0</doubleProperty>
>             <integerProperty>21</integerProperty>
>             <longProperty>22</longProperty>
>             <stringProperty>b</stringProperty>
>          </in14>
>       </soapenv:Body>
>    </soapenv:Envelope>
> And the wsdd extract too :
>       <operation name="testFlatBeanPairToFlatBean" qname="testFlatBeanPairToFlatBean"
returnQName="retNS:testFlatBeanPairToFlatBeanReturn" xmlns:retNS="urn:axis-test3" returnType="rtns:FlatBean"
xmlns:rtns="urn:axis-test3" soapAction="" >
>         <parameter qname="pns:in13" xmlns:pns="urn:axis-test3" type="tns:FlatBean"
xmlns:tns="urn:axis-test3"/>
>         <parameter qname="pns:in14" xmlns:pns="urn:axis-test3" type="tns:FlatBean"
xmlns:tns="urn:axis-test3"/>
>       </operation>
> But the server class always receives null for the second parameter...
> See the attachments...

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message