axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Deepal Jayasinghe" <dee...@opensource.lk>
Subject Re: [Axis2] Re: Trying to deploy the sample service with the latest code
Date Sat, 04 Jun 2005 05:16:54 GMT
Hi Paul;

I can not see any problem in ur service archive file and infact it works
fine with me. I think the problem might be in ur invocation codes I mean
client side so pls chcek that. I have attached a Test class that u can ues
to test ur service.


Thanks

Deepal


> Deepal
>
> Here is the sample JAR file.
>
> Here is the stack trace.
>
> org.apache.axis.engine.AxisFault: No Operation named "echo" Not found
>         at
> org.apache.axis.engine.AddressingBasedDispatcher.findOperation(Addres
> singBasedDispatcher.java:52)
>         at
> org.apache.axis.engine.AbstractDispatcher.invoke(AbstractDispatcher.j
> ava:63)
>         at org.apache.axis.engine.Phase.invoke(Phase.java:162)
>         at
> org.apache.axis.engine.AxisEngine.invokePhases(AxisEngine.java:213)
>         at org.apache.axis.engine.AxisEngine.receive(AxisEngine.java:108)
>         at
> org.apache.axis.transport.http.AxisServlet.doPost(AxisServlet.java:26
> 2)
>         at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
>         at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
>         at
> org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
> icationFilterChain.java:252)
>         at
> org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
> ilterChain.java:173)
>         at
> org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperV
> alve.java:213)
>         at
> org.apache.catalina.core.StandardContextValve.invoke(StandardContextV
> alve.java:178)
>         at
> org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.j
> ava:126)
>         at
> org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.j
> ava:105)
>         at
> org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineVal
> ve.java:107)
>         at
> org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.jav
> a:148)
>         at
> org.apache.coyote.http11.Http11Processor.process(Http11Processor.java
> :856)
>         at
> org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.proce
> ssConnection(Http11Protocol.java:744)
>         at
> org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpo
> int.java:527)
>         at
> org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFol
> lowerWorkerThread.java:80)
>         at
> org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadP
> ool.java:684)
>         at java.lang.Thread.run(Thread.java:534)
> org.apache.axis.engine.AxisFault: No Operation named "echo" Not found
>         at
> org.apache.axis.engine.AddressingBasedDispatcher.findOperation(Addres
> singBasedDispatcher.java:52)
>         at
> org.apache.axis.engine.AbstractDispatcher.invoke(AbstractDispatcher.j
> ava:63)
>         at org.apache.axis.engine.Phase.invoke(Phase.java:162)
>         at
> org.apache.axis.engine.AxisEngine.invokePhases(AxisEngine.java:213)
>         at org.apache.axis.engine.AxisEngine.receive(AxisEngine.java:108)
>         at
> org.apache.axis.transport.http.AxisServlet.doPost(AxisServlet.java:26
> 2)
>         at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
>         at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
>         at
> org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
> icationFilterChain.java:252)
>         at
> org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
> ilterChain.java:173)
>         at
> org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperV
> alve.java:213)
>         at
> org.apache.catalina.core.StandardContextValve.invoke(StandardContextV
> alve.java:178)
>         at
> org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.j
> ava:126)
>         at
> org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.j
> ava:105)
>         at
> org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineVal
> ve.java:107)
>         at
> org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.jav
> a:148)
>         at
> org.apache.coyote.http11.Http11Processor.process(Http11Processor.java
> :856)
>         at
> org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.proce
> ssConnection(Http11Protocol.java:744)
>         at
> org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpo
> int.java:527)
>         at
> org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFol
> lowerWorkerThread.java:80)
>         at
> org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadP
> ool.java:684)
>         at java.lang.Thread.run(Thread.java:534)
>
>
>
> On 6/3/05, Deepal Jayasinghe <deepal@opensource.lk> wrote:
>> Hi Paul;
>>
>> I can not give the correct answer without looking at the source codes ,
>> if
>> you can pls send your service archive file and corresponding source
>> files to
>> mailing list or to me , then I can take a look at that.
>>
>> BTW at which point did u get this exception ?
>>
>>
>> Deepal
>>
>> ----- Original Message -----
>> From: "Paul Fremantle" <pzfreo@gmail.com>
>> To: <axis-dev@ws.apache.org>
>> Sent: Friday, June 03, 2005 4:24 PM
>> Subject: Re: Trying to deploy the sample service with the latest code
>>
>>
>> Ok now I'm getting a fault
>>
>> AxisFault: No Operation named "echo" Not found. I have a method called
>> echo in my class and a <operation name="echo"/> in my service.xml.
>>
>> Any ideas?
>>
>> Paul
>>
>> On 6/3/05, Deepal Jayasinghe <deepal@opensource.lk> wrote:
>> > Hi all;
>> > I forgot to tell every thing in the previous mail , in the current
>> > implementation it can possible to specify operations specific
>> > messgeRecievers , if you don't do so default message receiver will
>> acts as
>> > the messageReciever.
>> >
>> > Any way why don't u take a look at the deployment sample there I have
>> > implemented useful services
>> >
>> > core/sample/deployment
>> >
>> > Thanks and regard
>> > Deepal
>> >
>> > ----- Original Message -----
>> > From: "Deepal Jayasinghe" <deepal@opensource.lk>
>> > To: <axis-dev@ws.apache.org>; "Paul Fremantle" <pzfreo@gmail.com>
>> > Sent: Friday, June 03, 2005 3:35 PM
>> > Subject: Re: Trying to deploy the sample service with the latest code
>> >
>> >
>> > > hi paul
>> > >
>> > > <service name="">
>> > >        <description>
>> > >           This service echo the given input , and this was developed
>> to
>> > > text the axis system working
>> > >            correctly
>> > >        </description>
>> > >        <parameter name="ServiceClass"
>> > > locked="xsd:false">org.apache.axis.echo.Echo</parameter>
>> > >        <operation name="echoOMElement"/>
>> > >        <operation name="echoString"/>
>> > > </service>
>> > >
>> > >
>> > > This is service.xml corresponds to an echo service
>> > > parameter ServiceClass is the service implemenattion class.
>> > >
>> > > Thanks and regards
>> > >
>> > > Deepal
>> > >
>> > > ----- Original Message -----
>> > > From: "Paul Fremantle" <pzfreo@gmail.com>
>> > > To: <axis-dev@ws.apache.org>
>> > > Sent: Friday, June 03, 2005 3:21 PM
>> > > Subject: Trying to deploy the sample service with the latest code
>> > >
>> > >
>> > > Hi
>> > >
>> > > I'm trying to deploy the sample service on the latest code. The
>> > > service.xml seems to have changed since M1. Can someone please post
>> a
>> > > working service.xml!???
>> > >
>> > > Paul
>> > >
>> > >
>> >
>> >
>>
>>
>

Mime
View raw message