Hi, I did It, but still the same Server exception. I write this wsdl to create the simpler similar situation as with  StyledLayerDescription.xsd,what I solve. So it is my wsdl correct?
            Ales
----- Original Message -----
From: Anne Thomas Manes
To: axis-dev@ws.apache.org
Sent: Wednesday, December 14, 2005 4:36 PM
Subject: Re: Is it a bug? Multi-nested includes. Server.generalException - makeTypeElement() was told to create a type ...

You must use <xsd:include> to bring in a schema with the same namespace and <xsd:import> to bring in a schema with a different namespace. So you must change this:

<xsd:schema targetNamespace=" http://www.opengis.net/ows">
  <xsd:import namespace="http://www.opengis.net/ows "  
     schemaLocation
="./wms_schemas.xsd" />
</
xsd:schema>
<xsd:schema targetNamespace=" http://www.opengis.net/bla">
  <xsd:import namespace=" http://www.opengis.net/bla"
 schemaLocation="./wms-pok2.xsd" />
  </xsd:schema>

to this:

<xsd:schema targetNamespace=" http://www.opengis.net/ows">
  <xsd:include schemaLocation=" ./wms_schemas.xsd" />
  </xsd:schema>
<xsd:schema targetNamespace=" http://www.opengis.net/bla">
  <xsd:include schemaLocation=" ./wms-pok2.xsd" />
  </xsd:schema>

Anne

On 12/14/05, Ales St <stanax@seznam.cz> wrote:
Hi
I have a problem with multi-nested includes, and I thing that it is a bug. I use java Axis 1.3.
I try in my wsdl file to import two difrent namespaces from two difrent xsd files. And then I generate classes using WSDL2JAVA (org.apache.axis.wsdl.WSDL2Java -v -a --server-side  --skeletonDeploy true --NStoPkg urn:Wms=wms wms.wsdl ) Then I copy files to server and when I wanted to see server generated wsdl Axis error is generated:
 
AXIS error
Sorry, something seems to have gone wrong... here are the details:
Fault - makeTypeElement() was told to create a type "{http://www.opengis.net/bla}>zzbb", with no containing element
AxisFault
faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.generalException
faultSubcode:
faultString: makeTypeElement() was told to create a type "{http://www.opengis.net/bla}>zzbb", with no containing element
faultActor:
faultNode:
faultDetail:
{http://xml.apache.org/axis/}hostname:pocitac

So my question is it is possible to import in wsdl two difrent schemas?Or not and it is a bug. I enclose some files which demonstrate this problem. I hope, that they are good writed because I beginner in soap. If it is not bug, please write to me, how to solve this problem, because it is wery important.
Thank you
                Ales