axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill Nagy <n...@watson.ibm.com>
Subject Re: [Axis2] More on not being able to build from source
Date Wed, 08 Feb 2006 14:36:08 GMT
Continuing on, I did a 'maven clean jar -Dmaven.test.skip=true' which
worked, followed by a 'maven war -Dmaven.test.skip=true' which did not
work quite so well:

Apache Axis 2.0 - Web Application
+----------------------------------------
| Executing (): Apache Axis 2.0 - Web Application
| Memory: 20M/41M
+----------------------------------------
Attempting to download commons-fileupload-1.0.jar.
21K downloaded
Attempting to download XmlSchema-1.0-SNAPSHOT.jar.
Attempting to download axiom-1.0-SNAPSHOT.jar.
Attempting to download policy-1.0-SNAPSHOT.jar.
Attempting to download wss4j-SNAPSHOT.jar.
    [echo] Copying Apache Axis 2.0 - Web Application to
target/temp/cache/war
truetruetruetruetruetruetruetruetruetruetruetruetruetruetruetruetruetruetruetruetruetruetrue
   [copy] Copying 23 files to /home/nagy/work/apache/axis2/target/temp/cache/war

war:
    [mkdir] Created
dir: /home/nagy/work/apache/axis2/target/temp/war/lib
    [mkdir] Created
dir: /home/nagy/work/apache/axis2/target/temp/war/toWEB-INF/modules
    [mkdir] Created
dir: /home/nagy/work/apache/axis2/target/temp/war/toWEB-INF/services
    [mkdir] Created
dir: /home/nagy/work/apache/axis2/target/temp/war/toWEB-INF/conf
    [jar] Building
jar: /home/nagy/work/apache/axis2/target/temp/war/lib/axis2-kernel-0.95-
SNAPSHOT.jar
    [copy] Copying 1 file
to /home/nagy/work/apache/axis2/target/temp/war/lib
    [copy] Copying 1 file
to /home/nagy/work/apache/axis2/target/temp/war/lib
    [copy] Copying 1 file
to /home/nagy/work/apache/axis2/target/temp/war/lib
    [copy] Copying 1 file
to /home/nagy/work/apache/axis2/target/temp/war/toWEB-INF/modules

BUILD FAILED
File...... /home/nagy/work/apache/axis2/maven.xml
Element... ant:copy
Line...... 394
Column.... 62
/home/nagy/work/apache/axis2/modules/samples/target/toWar/services not
found.
Total time: 11 minutes 45 seconds
Finished at: Wed Feb 08 08:52:32 EST 2006

However, when I followed that with a 'maven war', the build seems to
have completed properly.  Just thought that I would let you know.
 
-Bill
nagy@watson.ibm.com

On Wed, 2006-02-08 at 08:26 -0500, Bill Nagy wrote: 
> (I'll reply to my original message since my mail server seems to only
> like to deliver messages from axis-dev sporadically...)
> 
> Thanks.  I missed the project.properties file, and yes, I can get to
> http://cvs.apache.org/repository/, I just didn't realize that that's
> where some of the jars were.  (I attempted to set up caching proxy for
> the jars since it was taking over 4 hours to fetch them from ibiblio,
> only to fail later on, but I missed the apache repos.)  I see that
> Sanjiva fixed the war target, so I'll try again.
> 
> How often do the jars get updated in the repositories?  (i.e. how often
> should I not use the -o option?)
> 
> -Bill
> nagy@watson.ibm.com
> 
> On Tue, 2006-02-07 at 22:12 -0500, Bill Nagy wrote:
> > I apologize for not being able to continue on the previous thread, but
> > the messages were accidentally being marked as spam for me and were
> > deleted.  (I read your responses on the archive.)
> > 
> > I've tried several different JDKs, all with the same result.  For now,
> > I've chalked it up to some OS issue and simply deleted the test case --
> > everything in the default target then built fine.  However, when I try
> > to build the 'war' or 'release' targets, I get a dependency failure:
> > 
> > cache-war-deps:
> >     [echo] Fetching Dependencies for
> > modules: ,modules/webapp/project.xml
> > Starting the reactor...
> > Our processing order:
> > Apache Axis 2.0 - Web Application
> > +----------------------------------------
> > | Executing (): Apache Axis 2.0 - Web Application
> > | Memory: 15M/36M
> > +----------------------------------------
> > Attempting to download XmlSchema-1.0-SNAPSHOT.jar.
> > Attempting to download ws-policy-1.0-SNAPSHOT.jar.
> > WARNING: Failed to download ws-policy-1.0-SNAPSHOT.jar.
> > Attempting to download wss4j-SNAPSHOT.jar.
> > 
> > 
> > Actually I've spent the better part of two days both at home and at work
> > trying to get the build to fetch all of the dependencies, which makes me
> > less than happy with Maven...  In any event, I looked on both the
> > ibiblio and openejb repositories (or whatever they are -- I won't
> > pretend to understand Maven), and can't even find a ws-commons directory
> > (to be honest, I'm not sure how I got some of the other jars that also
> > appear to need to come from the same directory.)
> > 
> > Could someone please fill me in on what I'm missing (and tell me if
> > there are any more responsive mirrors)?  Thanks again.
> > 
> > -Bill
> > nagy@watson.ibm.com


Mime
View raw message