axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "wismax (JIRA)" <j...@apache.org>
Subject [jira] Created: (AXIS2-1216) org.w3c.dom.DOMException: WRONG_DOCUMENT_ERR when using codegen
Date Fri, 22 Sep 2006 07:33:22 GMT
org.w3c.dom.DOMException: WRONG_DOCUMENT_ERR when using codegen
---------------------------------------------------------------

                 Key: AXIS2-1216
                 URL: http://issues.apache.org/jira/browse/AXIS2-1216
             Project: Apache Axis 2.0 (Axis2)
          Issue Type: Bug
          Components: Tools
         Environment: jdk-1.5
            Reporter: wismax


When using codegen for a specific WSDL, I get the following exception:

Caused by: org.w3c.dom.DOMException: WRONG_DOCUMENT_ERR: A node is used in a different document
than the one that created it.
     [java] at com.sun.org.apache.xerces.internal.dom.ParentNode.internalInsertBefore(ParentNode.java:389)
     [java] at com.sun.org.apache.xerces.internal.dom.ParentNode.insertBefore(ParentNode.java:321)
     [java] at com.sun.org.apache.xerces.internal.dom.NodeImpl.appendChild(NodeImpl.java:275)
     [java] at org.apache.axis2.description.WSDL11ToAxisServiceBuilder.createSchemaForPorttype(WSDL11ToAxisServiceBuilder.java:1240)


It seems that at line 1240 of WSDL11ToAxisServiceBuilder, a "ownerDocument.import" is missing
when appending the child. I tested this fix against the 20060920 snapshot and it works.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message