axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jorge Fernández (JIRA) <>
Subject [jira] Commented: (AXIS2-2088) wsdl2java JiBX code generator and -Ebindingfile option unavailable in ant task
Date Sat, 21 Apr 2007 23:27:15 GMT


Jorge Fernández commented on AXIS2-2088:

Finally I've done it!!!

Thanks a lot. I had already tried what you said but the only problem 
I had was that I had dropped  the default="elements" attribute for the 
namespace definition in the binding and when I put it back It worked 

Thanks for the references. I had already read them but there is always 
something I can miss.

If you let me I would like to ask one last question: Does JiBX work with rampart??
I'm asking this because I have rampar module engaged but I wasn't using it at this
service and I get an exception besides I checked that the response message was
built correctly:

org.apache.axis2.AxisFault: Error in extracting message properties
	at org.apache.axis2.description.OutInAxisOperationClient.send(
	at org.apache.axis2.description.OutInAxisOperationClient.execute(
	at client.LoginServiceJiBXStub.webLogin(
	at client.Client.main(
Caused by: java.lang.Exception: org.apache.axis2.AxisFault: Error in extracting message properties;
nested exception is: 
	org.apache.rampart.RampartException: Error in extracting message properties
	at org.apache.rampart.handler.RampartSender.invoke(
	at org.apache.axis2.engine.Phase.invoke(
	at org.apache.axis2.engine.AxisEngine.invoke(
	at org.apache.axis2.engine.AxisEngine.send(
	at org.apache.axis2.receivers.AbstractInOutSyncMessageReceiver.receive(
	at org.apache.axis2.engine.AxisEngine.receive(
	at org.apache.axis2.transport.http.HTTPTransportUtils.processHTTPPostRequest(
	at org.apache.axis2.transport.http.AxisServlet.doPost(
	at javax.servlet.http.HttpServlet.service(
	at javax.servlet.http.HttpServlet.service(
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(
	at org.apache.catalina.core.StandardWrapperValve.invoke(
	at org.apache.catalina.core.StandardContextValve.invoke(
	at org.apache.catalina.core.StandardHostValve.invoke(
	at org.apache.catalina.valves.ErrorReportValve.invoke(
	at org.apache.catalina.core.StandardEngineValve.invoke(
	at org.apache.catalina.connector.CoyoteAdapter.service(
	at org.apache.coyote.http11.Http11Processor.process(
	at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(
	at org.apache.tomcat.util.threads.ThreadPool$
	at Source)
Caused by: org.apache.rampart.RampartException: Error in extracting message properties
	at org.apache.rampart.RampartMessageData.<init>(
	at org.apache.rampart.handler.RampartSender.invoke(
	... 23 more
Caused by: Error in converting SOAP Envelope to
Document; nested exception is:
	at org.apache.rampart.util.Axis2Util.getDocumentFromSOAPEnvelope(
	at org.apache.rampart.RampartMessageData.<init>(
	... 25 more
Caused by:
	at org.apache.rampart.util.Axis2Util.getDocumentFromSOAPEnvelope(
	... 26 more
Caused by:
	... 29 more

	at org.apache.axis2.AxisFault.<init>(
	... 4 more

> wsdl2java  JiBX code generator and -Ebindingfile option unavailable in ant task
> -------------------------------------------------------------------------------
>                 Key: AXIS2-2088
>                 URL:
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: codegen
>    Affects Versions: 1.1.1
>         Environment: Windows XP SP2, jre 1.5 update 10, and 1.7.0
>            Reporter: Jorge Fernández
>         Assigned To: Dennis Sosnoski
>         Attachments: binding.xml, build.xml, LoginServiceJiBX.wsdl, new_binding.xml,,
> First the little question:  is there any way for passing the -Ebindingfile in the ant
task of wsdl2java? because I didn't find it.
> The big one: I'm having a problem with wsdl2java code generation. I'm trying JiBX databinding
in wrapped mode. I've got my objects defined, my wsdl definition of the service and  I made
my binding definition manually. I also made an ant task, following the steps of the jibx tutorial.
I generated the binding definition with JiBX tools.
> This is the problem:
> When I use the ant task for compiling the binding definition with the build.xml, everything
seems to go alright. After that, I would have to type some code for running the service and
that's why I decided to use wsdl2java.  When I use wsdl2java for code generation I get this
> I use the command like this:
> wsdl2java -uri LoginServiceJiBX.wsdl -o src\ -p loginjibx -ss -sd -d jibx -g -sn LoginServiceJiBX
-pn LoginEndpointPort -ns2p http://login=login,,http://login/types=login.types,http:/
> /,http://schemas.xmls
> -ssi -Ebindingfile binding.xml
> This is the trace:
> Using AXIS2_HOME:   D:\Programas\PFC\axis2-1.1.1
> Using JAVA_HOME:    D:\Programas\Java\jdk1.5.0_09
> Exception in thread "main" org.apache.axis2.wsdl.codegen.CodeGenerationException
> : java.lang.NullPointerException
>         at org.apache.axis2.wsdl.codegen.CodeGenerationEngine.generate(CodeGener
>         at org.apache.axis2.wsdl.WSDL2Code.main(
>         at org.apache.axis2.wsdl.WSDL2Java.main(
> Caused by: java.lang.NullPointerException
>         at org.jibx.runtime.impl.StAXReaderWrapper.getNamespace(StAXReaderWrappe
>         at org.jibx.runtime.impl.UnmarshallingContext.getNamespaceUri(Unmarshall
>         at org.jibx.runtime.QName.deserialize(
>         at org.jibx.binding.model.MappingElement.setQualifiedTypeName(MappingEle
>         at org.jibx.binding.model.MappingElement.JiBX_binding_unmarshalAttr_5_0(
>         at org.jibx.binding.model.JiBX_bindingMappingElement_access.unmarshal()
>         at org.jibx.binding.model.BindingElement.JiBX_binding_unmarshal_3_0(Bind
>         at org.jibx.binding.model.JiBX_bindingBindingElement_access.unmarshal()
>         at org.jibx.runtime.impl.UnmarshallingContext.unmarshalElement(Unmarshal
>         at org.jibx.binding.model.BindingElement.readBinding(
> :609)
>         at org.jibx.binding.model.BindingElement.readBinding(
> :625)
>         at org.apache.axis2.jibx.CodeGenerationUtility.engage(CodeGenerationUtil
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
> java:39)
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
>         at java.lang.reflect.Method.invoke(
>         at org.apache.axis2.wsdl.codegen.extension.JiBXExtension.engage(JiBXExte
>         at org.apache.axis2.wsdl.codegen.CodeGenerationEngine.generate(CodeGener
>         ... 2 more
> I made it also in unwrapped mode and there was no problem with that.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message