axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas (JIRA)" <axis-...@ws.apache.org>
Subject [jira] Updated: (AXIS-1947) possible bug in Axis 1.2.x related to document/literal
Date Fri, 28 Sep 2007 12:54:05 GMT

     [ https://issues.apache.org/jira/browse/AXIS-1947?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Davanum Srinivas updated AXIS-1947:
-----------------------------------

    Assignee:     (was: Davanum Srinivas)

> possible bug in Axis 1.2.x related to document/literal
> ------------------------------------------------------
>
>                 Key: AXIS-1947
>                 URL: https://issues.apache.org/jira/browse/AXIS-1947
>             Project: Axis
>          Issue Type: Bug
>            Reporter: Bo Wang
>         Attachments: hello_world.wsdl
>
>
> here's the situation: for an operation with doc/literal style and with NO input message
part,  
>     <message name="request_reference"/>
>     <message name="return_reference">
>         <part element="tns:reference_wrapper" name="the_reference"/>
>     </message>
>     <portType name="Factory">
>         <operation name="retrieve_reference">
>             <input message="tns:request_reference" name="retrieve_referenceRequest"/>
>             <output message="tns:return_reference" name="retrieve_referenceResponse"/>
>         </operation>
>     </portType>
>     <binding name="Factory_SOAPBinding" type="tns:Factory">
>         <soap:binding style="document" transport="http://schemas.xmlsoap.org/soap/http"/>
>         <operation name="retrieve_reference">
>             <soap:operation soapAction="" style="document"/>
>             <input name="retrieve_referenceRequest">
>                 <soap:body use="literal"/>
>             </input>
>             <output name="retrieve_referenceResponse">
>                 <soap:body use="literal"/>
>             </output>
>         </operation>
>     </binding>
> Axis sends the following message with an empty operation in soap body. 
> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema"

> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
>     <soapenv:Body>
>         <retrieve_reference xmlns="http://www.iona.com/hello_world_soap_http"/>
>     </soapenv:Body>
> </soapenv:Envelope>
> but the following is the soap message with an empty soap body:
> <?xml version='1.0' encoding='utf-8'?>
> <SOAP-ENV:Envelope xmlns:xs="http://www.w3.org/2001/XMLSchema" 
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
> xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
>     <SOAP-ENV:Body></SOAP-ENV:Body>
> </SOAP-ENV:Envelope>
> this happens in axis 1.2 beta, rc1, rc2, and rc3. (java version)
> I think it's a bug, isn't it?

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message