axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-3511) Axis doesn't send default values
Date Sun, 09 Mar 2008 02:59:46 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-3511?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12576680#action_12576680
] 

Davanum Srinivas commented on AXIS2-3511:
-----------------------------------------

Please submit a test with a wsdl. we don't have enough information to do anything with this
issue.

> Axis doesn't send default values
> --------------------------------
>
>                 Key: AXIS2-3511
>                 URL: https://issues.apache.org/jira/browse/AXIS2-3511
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>    Affects Versions: 1.3
>            Reporter: Haneef Ali
>
> <xsd:complexType name="MyType">
> <xsd:element name="myName" default="SomeName" />
> </xsd:complexType>
> If the client doesn't set the value of the field myName, then Axis needs to set it to
default value, since it is a required field. Axis doesn't do that
> Haneef

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message