axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thilina Gunarathne" <cset...@gmail.com>
Subject Re: [Axis2] response content
Date Thu, 05 Jun 2008 06:57:43 GMT
Is it whether my following reply did not answer ur questions or whether you
simply missed it..
http://markmail.org/message/lt65mrgnkr7egqjk

The earlier mails in axis-dev related to this...
http://markmail.org/message/rrtsu7x22pkwya2e

 IMHO I do not think this as a much of a limitation given that users can
enable MTOM per operation wise and also they can use "optional" for
enableMTOM..

thanks,
Thilina

On Wed, Jun 4, 2008 at 10:28 PM, Tony Dean <Tony.Dean@sas.com> wrote:

> Anyone have any answers to the question below.  Thanks.
>
> > -----Original Message-----
> > From: Tony Dean [mailto:Tony.Dean@sas.com]
> > Sent: Tuesday, June 03, 2008 4:41 PM
> > To: axis-dev@ws.apache.org
> > Subject: [Axis2] response content
> >
> > Hi,
> >
> > I have a web service that is returning XML... it's schema type is
> > xsd:any.  I would expect the content to be returned as follows:
> >
> > HTTP/1.0 200 OK
> > Content-Type: text/xml
> >
> > <?xml version='1.0' encoding='UTF-8'?>
> > <soapenv:Envelope>
> >    <soapenv:Body>
> >         ...
> >    </soapenv:Body>
> > </soapenv:Envelope>
> >
> >
> > I would expect this to be returned whether MTOM is enabled or not.
> > Wouldn't you?
> >
> >
> > Here's the response from Axis2 service when MTOM is disabled in the
> > Axis2.conf server config file:
> >
> > HTTP/1.0 200 OK
> > Proxy-Connection: close
> > X-Powered-By: Servlet 2.4; JBoss-4.2.1.GA (build: SVNTag=JBoss_4_2_1_GA
> > date=200707131605)/Tomcat-5.5
> > X-Cache-Lookup: MISS from inetgw04.unx.sas.com:80
> > Date: Tue, 03 Jun 2008 20:10:23 GMT
> > X-Cache: MISS from inetgw04.unx.sas.com
> > Content-Type: text/xml;charset=UTF-8
> > Server: Apache-Coyote/1.1
> >
> > <?xml version='1.0' encoding='UTF-8'?>
> > <soapenv:Envelope
> > xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
> >     <soapenv:Body>
> >         .....
> >     </soapenv:Body>
> > </soapenv:Envelope>
> >
> >
> > Looks correct.
> >
> > -----------------------------------------------------------------------
> > -------------------------------------------------
> >
> > Here's the response from Axis2 service when MTOM is enabled in the
> > Axis2.conf server config file:
> >
> > HTTP/1.0 200 OK
> > Proxy-Connection: close
> > X-Powered-By: Servlet 2.4; JBoss-4.2.1.GA (build: SVNTag=JBoss_4_2_1_GA
> > date=200707131605)/Tomcat-5.5
> > X-Cache-Lookup: MISS from inetgw04.unx.sas.com:80
> > Date: Tue, 03 Jun 2008 20:27:29 GMT
> > X-Cache: MISS from inetgw04.unx.sas.com
> > Content-Type: multipart/related;
> > boundary=MIMEBoundaryurn_uuid_93D2E13819F92A45691212524849948;
> > type="application/xop+xml";
> > start="0.urn:uuid:93D2E13819F92A45691212524849949@apache.org<0.urn%3Auuid%3A93D2E13819F92A45691212524849949@apache.org>";
> start-
> > info="text/xml"
> > Server: Apache-Coyote/1.1
> >
> > --MIMEBoundaryurn_uuid_93D2E13819F92A45691212524849948
> > Content-Type: application/xop+xml; charset=UTF-8; type="text/xml"
> > Content-Transfer-Encoding: binary
> > Content-ID: <0.urn:uuid:93D2E13819F92A45691212524849949@apache.org<0.urn%3Auuid%3A93D2E13819F92A45691212524849949@apache.org>
> >
> >
> > <?xml version='1.0' encoding='UTF-8'?>
> > <soapenv:Envelope
> > xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
> >    <soapenv:Body>
> >       ....
> >    </soapenv:Body>
> > </soapenv:Envelope>
> >
> >
> > Why use multipart/related content type when there are no attachments?
> > That is,  why make an attachment out of the SOAP envelope itself when
> > there are no real attachments?  Is this correct behavior?
> >
> > I'd like to hear your comments.
> >
> > Thanks.
> >
> >
> > Tony Dean
> > SAS Institute Inc.
> > 919.531.6704
> > tony.dean@sas.com
> >
> > SAS... The Power to Know
> > http://www.sas.com
> >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
> > For additional commands, e-mail: axis-dev-help@ws.apache.org
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>


-- 
Thilina Gunarathne - http://thilinag.blogspot.com

Mime
View raw message