axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Veithen (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-4141) generating empty <service> tag in wsdl after server restart
Date Mon, 01 Dec 2008 20:23:44 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-4141?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12652138#action_12652138
] 

Andreas Veithen commented on AXIS2-4141:
----------------------------------------

Can you attach the axis2.xml file you are using in your web app?

> generating empty <service> tag in wsdl after server restart
> -----------------------------------------------------------
>
>                 Key: AXIS2-4141
>                 URL: https://issues.apache.org/jira/browse/AXIS2-4141
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: kernel
>    Affects Versions: 1.4
>         Environment: AIX, tomcat 6
> java version "1.5.0"
> Java(TM) 2 Runtime Environment, Standard Edition (build pap32dev-20080315 (SR7))
> IBM J9 VM (build 2.3, J2RE 1.5.0 IBM J9 2.3 AIX ppc-32 j9vmap3223-20080315 (JIT enabled)
>            Reporter: Eduard
>            Priority: Minor
>
> Then I'm restarting Tomcat and getting WSDL (via http://URL/..?wsdl) I'm getting empty
<service> tag  (<wsdl:service name="IRunService"/>)
> If I redeploy service then wsdl is being generated fine.
> After some digging in the code I found following:
> 1) after tomcat's restart in /org/apache/axis2/description/AxisService2WSDL11.java at
generateSoap11Port() method service doesn't have any endpoints (axisService.getEndpoints().size()
== 0)
> 2) endpoints of service are populated from "global" endpoints list at AxisServlet::init(ServletConfig
config) during services deployment
> 3) "global" endpoints seem to be populated at AxisServlet::init(ServletConfig config)
method too [b]but[/b] after deployment of services and therefore during initial deployment
services don't get any endpoints. If we redeploy service then it gets correct list of endpoints

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message