axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Håkon Sagehaug <Hakon.Sageh...@bccs.uib.no>
Subject Re: Failed when creating xmlbeans binding from WS-Trust.wsdl
Date Mon, 26 Jan 2009 13:42:16 GMT
Hi

I can compile the schema on it's own using xmlbeans, but not when I want to
create ws stub classes using the xmlbeans binding.

cheers, Håkon

2009/1/26 Håkon Sagehaug <Hakon.Sagehaug@bccs.uib.no>

> Hi
>
> I wanted to make a STS service and copied the WS-Trust.wsdl from the
> ws-trust specification and added binding and service description, but when I
> want to create an xmlbeans binding I  get this error
>
> Caused by: java.lang.RuntimeException: org.apache.xmlbeans.XmlException:
> http://schemas.xmlsoap.org/ws/2004/08/addressing/:61:1: error:
> cvc-enumeration-valid: string value 'none' is not a valid enumeration value
> for type of processContents attribute in xs:wildcard
>
>
> I use this command
>
>  wsdl2java.sh -uri wsdl/WS-Trust.wsdl -ss -d xmlbeans -sd -p
> no.plab.hakont.sts -s
>
> and running axis2 1.4.1
>
> Any hits on this, since I 've not done anything else then adding a binding
> and service to the wsdl I dont get what's wrong in this case.
>
> cheers, Håkon
>
> --
> Håkon Sagehaug, Software Developer
> Parallab, Bergen Center for Computational Science (BCCS)
> UNIFOB AS (University of Bergen Research Company)
>



-- 
Håkon Sagehaug, Software Developer
Parallab, Bergen Center for Computational Science (BCCS)
UNIFOB AS (University of Bergen Research Company)

Mime
View raw message