axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Veithen <andreas.veit...@gmail.com>
Subject Re: svn commit: r776172 - in /webservices/axis2/trunk/java/modules: jaxws/src/org/apache/axis2/jaxws/handler/SOAPHeadersAdapter.java kernel/src/org/apache/axis2/deployment/DeploymentEngine.java kernel/src/org/apache/axis2/engine/AxisConfiguration.jav
Date Tue, 19 May 2009 12:50:47 GMT
Interesting. I didn't know that the semantics of @Override changed
between 1.5 and 1.6. Thanks for the explanation!

Andreas

On Tue, May 19, 2009 at 13:25, Glen Daniels <glen@thoughtcraft.com> wrote:
> Hi Andreas:
>
> Andreas Veithen wrote:
>> What do you mean by JDK 1.5 can't compile @Override annotations???
>
> In JDK 1.5, @Override is supported only for superclass methods, and using it
> on an interface method produces a compiler error. :(  This sucks, but until
> we move off 1.5 that's what we seem stuck with.
>
> http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=5008260
>
> --Glen
>

Mime
View raw message