axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathon Roberts (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-3852) A module in the module folder works on al services
Date Thu, 06 Aug 2009 13:55:15 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-3852?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12740071#action_12740071
] 

Jonathon Roberts commented on AXIS2-3852:
-----------------------------------------

I can confirm this problem.  I've got <module ref="myModule"/> set for just one of my
services in service.xml, but it's getting applied to all the services in axis2 including the
version service.  There seems to be no way to engage a module for just one service.

> A module in the module folder works on al services
> --------------------------------------------------
>
>                 Key: AXIS2-3852
>                 URL: https://issues.apache.org/jira/browse/AXIS2-3852
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: modules
>    Affects Versions: 1.4, 1.3
>         Environment: Windows XP, sun java 1.4.2_11 Tomcat 5.0.28
>            Reporter: Jaap Droogers
>            Priority: Minor
>
> When I create a new module, the invoke() method is called with every call to all the
services.
> I expect this behavier only when axis2.xml contains the element <module ref="myModule"/>
> I tested this in axis2 version 1.3 and 1.4

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message