axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Veithen <andreas.veit...@gmail.com>
Subject Re: Build failures in Rampart 1.5?
Date Mon, 30 Aug 2010 18:46:48 GMT
Glen,

This seems to be caused by a bug in Sun's JDK 1.5 (all versions,
except 1.5.0_24 distributed on MacOS X only). Please use 1.6.

Andreas

On Mon, Aug 30, 2010 at 18:49, Glen Daniels <glen@thoughtcraft.com> wrote:
> Hi folks,
>
> When I try to rebuild Rampart 1.5 from source, there seem to be two
> repeatable build failures in the integration module:
>
> Failed tests:
>  testRequest(org.apache.rahas.RahasSAML2TokenTest)
>  testRequest(org.apache.rahas.RahasSAML2TokenCertForHoKTest)
>
> The first fails due to an isRecognizedEncoding problem, the second due to
> being unable to initialize org.apache.rahas.impl.SAML2TokenIssuer.
>
> I haven't dug deeply into this, but it's a little scary.  Nandana, this must
> have built correctly when you cut the release, right?  Any clue what might
> have happened in the meanwhile?  I'm using
> https://svn.apache.org/repos/asf/axis/axis2/java/rampart/branches/1_5/ as the
> SVN URL.
>
> (Context - trying to determine which versions of the HTTPClient reuse code
> are working or not with Rampart.)
>
> Thanks,
> --Glen
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
> For additional commands, e-mail: java-dev-help@axis.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message