axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Veithen <andreas.veit...@gmail.com>
Subject Re: Should mail-1.4.jar distributed with axis2 ?
Date Sun, 22 Aug 2010 14:08:37 GMT
I've reworked a bit the webapp module (on the trunk and the 1.5
branch). It should now contain all the necessary JARs.

Andreas

On Fri, Aug 20, 2010 at 09:43, Amila Jayasekara <amilaj@wso2.com> wrote:
> Hi Andreas,
>   I am on revision 987379. Yes this is fixed for binary distribution. Here
> with this mail i am attaching a patch to fix in war distribution.
>
> Thanks
> AmilaJ
>
> Andreas Veithen wrote:
>>
>> That issue should be fixed by r985715 (on the trunk) and r985716 (on
>> the 1.5 branch), at least for the binary distribution. We indeed need
>> to check the WAR distribution. That is on my todo list.
>>
>> Andreas
>>
>> On Fri, Aug 20, 2010 at 08:30, Amila Jayasekara <amilaj@wso2.com> wrote:
>>
>>>
>>> Hi All,     I am carrying out few tests with axis2-1.5.2-SNAPSHOT. I
>>> deployed axis2-1.5.2-SNAPSHOT in tomcat version 5.5.20. When staring
>>> tomcat
>>> i found following error in ${tomcat_home}/logs/catalina.out.
>>>
>>> [ERROR] StandardWrapper.Throwable
>>> java.lang.NoClassDefFoundError: javax/mail/internet/ParseException
>>>      at
>>>
>>> org.apache.axis2.deployment.AxisConfigBuilder.populateConfig(AxisConfigBuilder.java:207)
>>>      at
>>>
>>> org.apache.axis2.deployment.DeploymentEngine.populateAxisConfiguration(DeploymentEngine.java:703)
>>>      at
>>>
>>> org.apache.axis2.deployment.WarBasedAxisConfigurator.<init>(WarBasedAxisConfigurator.java:157)
>>>      ....
>>>      ....
>>> Caused by: java.lang.ClassNotFoundException:
>>> javax.mail.internet.ParseException
>>>      at
>>>
>>> org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1355)
>>>      at
>>>
>>> org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1201)
>>>
>>> Later i  found mail-1.4.jar is not in the classpath and it is the, cause
>>> for
>>> above mentioned error. Thus mail-1.4.jar is also not deployed with
>>> axis2.war.
>>> So is this an issue or an expected behavior ? i.e. are we expecting users
>>> to
>>> have mail.1.4.jar in their class paths ?
>>> If mail-1.4.jar needs to be distributed with axis2 i can raise an issue
>>> and
>>> a submit a patch.
>>>
>>> Please give feedback.
>>>
>>> Thanks
>>> AmilaJ
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
>>> For additional commands, e-mail: java-dev-help@axis.apache.org
>>>
>>>
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
>> For additional commands, e-mail: java-dev-help@axis.apache.org
>>
>>
>>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message